Question Status

Verified
Amos asked a question on 26 Jul 2013 3:10 AM

I'm trying to set up Retail module with separated Server between AOS and DB server. both of them using Windows Server 2008 R2 and work on VM

  1. i already setup all the requirement properly
  2. The Synch Service has been installed on both server either it's on the AOS or DB server
  3. i already configure all the Synch profile, database profile, and AOS Profile. all of them already tested for connection and working properly
  4. the store database creation using retail database utility also work without any problem
the problem start when i'm using the distribution schedule. all the N-jobs log are work fine and stated successful. but when i check the DBO.outgoing message on the database there's no server message that usually mention how many record data affected by the job and there's no error mention by the system. when i check the Store DB it's also still blank.
can anybody help me with this problem?

Reply
Verified Answer
Michael Galderisi responded on 29 Jul 2013 6:20 AM

Ok. If they are both on the same server you should only need one Synch Service. This is how the AX 2012 R2 Demo is setup.

I have seen this error before. Shutdown the Synch Service and try deleting all the existing incoming and outgoing messages from the Synch Service message db(s). Then go in and delete the ques and temp files form the Synch Service Work folder(s). After this restart the Synch Service and try again.

Reply
Michael Galderisi responded on 27 Jul 2013 8:02 AM

From your description I am assuming you have the HQ Synch Service setup on the AOS and the Store Synch Service setup on the DB Server. Is this correct?

First off, under Retail\Retail scheduler\Channel integration\AOS profiles I would check to see what is set for the parameter Commerce Data Exchange: Synch Service. Check the Synch Service profile listed here and see what message database is linked to it. I call this the HQ Synch Service and the message database associated with it is where the packets go to first and then they are forwarded to the Store's Synch Service. If they do not make it here they will not make it to the Store Synch Service message database.

Reply
Amos responded on 29 Jul 2013 3:35 AM

@michael: the AOS and the store are on the same server. the separated are only the DB. on the DB server "Service Setting" and the AOS Server "Service Setting" using the same setting.

actually i was once succeed on populating the DB. but there's an error when i'm running N-job 1070 there's an error number 32769. when i try to re-run the job the synch service won't send the data anymore.

Reply
Verified Answer
Michael Galderisi responded on 29 Jul 2013 6:20 AM

Ok. If they are both on the same server you should only need one Synch Service. This is how the AX 2012 R2 Demo is setup.

I have seen this error before. Shutdown the Synch Service and try deleting all the existing incoming and outgoing messages from the Synch Service message db(s). Then go in and delete the ques and temp files form the Synch Service Work folder(s). After this restart the Synch Service and try again.

Reply
Amos responded on 30 Jul 2013 8:34 PM

@Michael: Thank you man. It's work like magic. now all the synch service can work properly

Reply
Michael Galderisi responded on 31 Jul 2013 7:29 AM

Your welcome. I am glad I could help you out.

Reply