Question Status

Verified
Narayan PS asked a question on 16 Feb 2014 6:10 AM

Hi I am getting this error "Object reference not set to an instance of an object." when i try to open a SSRSreport in ax 2012?

How could this be solved?

Already tried restarting Sql server reporting services .but din't work

Reply
Martin Dráb responded on 16 Feb 2014 8:15 AM

You'll get this error when you try to call a method or access a property on a null object. You'll need to collect more information about what fails to be able to fix it.

Is the problem only with a single report? Do you get the same problem in Visual Studio? Debugging there should be easier.

Martin "Goshoom" Dráb | Freelancer | Goshoom.NET Dev Blog

Reply
Piyush Ojha responded on 21 Feb 2014 6:57 AM

Hi Martin,

I am also facing this issue in PurchPurchaseOrder Report.

when I am clicking on the design in VS same error occur.

design not open due to this error.

I have already customize this report before this error occur.

What can i do for this........... ...

Thanks

Piyush Ojha

Reply
Verified Answer
Denis Macchinetti responded on 21 Feb 2014 7:10 AM

Hi guys

In my experience I solved this issue by running a Full Cil compilation.

Finally, in some cases I have also stop AOS, delete the XppIL folder, start AOS and running a Full CIL

Also, in the past I have installed the KB 2720601 for a similar problem.

"Assume that you create a drillthrough report in Microsoft Dynamics AX 2012. When you try to print preview a child report from the drillthrough report, you receive the following error message"

Regards

Thanks & Regards

Denis Macchinetti

Senior Technical Architect

Reply
Suggested Answer
Francisco Silva responded on 21 Feb 2014 9:28 AM

Does it happens with all AX reports? Try to re-deploy the BIServices Service Group from AOT.

Dont forget to mark this as answer!

Francisco Silva | | http://fsilvajunior.blogspot.com.br

This posting is provided "AS IS" with no warranties, and confers no rights.

Reply
Gopi Balakrishnan responded on 21 Feb 2014 11:19 AM

Try

1. Open AX as Admin

2. Restore and deploy the report

3. Restart  Reporting service

If it doesn't work,

Try restarting AOS.

Reply
Narayan PS responded on 27 Oct 2014 1:36 PM

CIL generation helped!

Reply
Rupa responded on 28 Oct 2014 8:16 PM

Hello There,

I have just started working on AX2012 reports. In the first report itself i could not able to add the report to report model. I am getting the "Object reference not set to an Instance of the object" error.

I have restarted the AOS service and deleted the Xpp, but the problem is not solved.

Someone please help me.

Reply
Verified Answer
Denis Macchinetti responded on 21 Feb 2014 7:10 AM

Hi guys

In my experience I solved this issue by running a Full Cil compilation.

Finally, in some cases I have also stop AOS, delete the XppIL folder, start AOS and running a Full CIL

Also, in the past I have installed the KB 2720601 for a similar problem.

"Assume that you create a drillthrough report in Microsoft Dynamics AX 2012. When you try to print preview a child report from the drillthrough report, you receive the following error message"

Regards

Thanks & Regards

Denis Macchinetti

Senior Technical Architect

Reply
Suggested Answer
Francisco Silva responded on 21 Feb 2014 9:28 AM

Does it happens with all AX reports? Try to re-deploy the BIServices Service Group from AOT.

Dont forget to mark this as answer!

Francisco Silva | | http://fsilvajunior.blogspot.com.br

This posting is provided "AS IS" with no warranties, and confers no rights.

Reply