Question Status

Suggested Answer
ARPIT CHAVHAN asked a question on 20 Jan 2013 11:04 PM

Dear All,

I have installed AX 2012 R2. Created a client configuration with a check of "enable break point" and saved it, but its giving me error as "Connection to the AOS could not be established. Though my services are already started. I also checked the port no. which is same as server config.

Also when I start my ax with normal AX icon, It starts fine but cannot use debbuger. I have installed debugger.

Plz let me know if any one can guide me how to resolve such problem.

Summary - Two Problems 

1) Not able to create client configuration

2) Not able to use debbuger .

Thank you.

Reply
ARPIT CHAVHAN responded on 21 Jan 2013 12:26 AM

I have resolved the client configuration issue....

but the debbugger problem is still on...

Any one ..................???????

Reply
ARPIT CHAVHAN responded on 21 Jan 2013 12:57 AM

My debugger has been started but with a blank screen.

Any one knows how to solve this problem ???

Reply
venkatesh vadlamani responded on 21 Jan 2013 1:58 AM

One question

IS the client user credentials present in this user group  "Microsoft Dynamics AX Debugging Users"?

Reply
ARPIT CHAVHAN responded on 21 Jan 2013 2:22 AM

yes already added...

Reply
Dick Wenning responded on 21 Jan 2013 5:26 AM

add the break point in the AOT and when you have the correct rights, the debugger will pop up.

incase code is running server side, an additional property on the AOS server configuration needs to be set.

When running in CIL, attach Visual studio to the AOS process. and add the breakpoint in the Visual studio AOT.

Kind regards, 

Kaya Solutions

Dick Wenning

+31 6 147 989 53 

Landjuweel 5

3905 PE - Veenendaal

 

OTHER CONTACT INFORMATION

Reply
ARPIT CHAVHAN responded on 21 Jan 2013 9:45 PM

I dont get it Dick... why do I need visual studio to start a debugger ?? And what setting do I need to do on server configuration.

Let me tell you once again what exactly is my problem....

1) I have installed debugger for ax 2012 r2.

2) I have checked enable breakpoint on server configuration as well as client configuration.

3) Also did setting on the tool option of the development environment as " debugger - on break point"

Now I have wrote one job and kept break point on it. When I am running it. My debugger pops up.

But, with a blank window, I mean the window where we can see the code in the debugger is blank.

Thats my problem. Why I cant see the code window where we press f10 go to the next line of code in the debugger. ?????

Plz suggest me something.

Reply
Dick Wenning responded on 22 Jan 2013 12:21 AM

ok that case the debugger is debugging a client session.

do see some eventlog messages on the Client machine?

sometimes it helps to log off and on in the client machine.

Kind regards, 

Kaya Solutions

Dick Wenning

+31 6 147 989 53 

Landjuweel 5

3905 PE - Veenendaal

 

OTHER CONTACT INFORMATION

Reply
somvir responded on 5 Feb 2013 6:51 AM

I have almost the same issue, but when I put a breakpoint in a job , debugger do not open. A message pop up saying debugger is not installed, please install the debugger. I installed it several time but same message.

Any suggestion.

Thanks in advance.

Reply
Suggested Answer
Tommy Skaue responded on 5 Feb 2013 2:49 PM

I believe if you are debugging code that is running in .Net, you need to make sure the folder containing the source files is filled up. Not sure if this happens when the AOS starts, or of you actually need to run a CIL-compile for it to be filled. The source folder is located under X:\Program Files\Microsoft Dynamics AX\60\Server\AOS_ID\bin\XppIL\source

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
Dick Wenning responded on 21 Mar 2013 3:43 AM

bad day,

I have the same in my current environment,

this environment also has ax 2009 installed

folks that follow this thread, do you have the same

Kind regards, 

Kaya Solutions

Dick Wenning

+31 6 147 989 53 

Landjuweel 5

3905 PE - Veenendaal

 

OTHER CONTACT INFORMATION

Reply
Dick Wenning responded on 21 Mar 2013 3:48 AM

found a work around,

start AX right mouse run as administrator. and it works!!

Kind regards, 

Kaya Solutions

Dick Wenning

+31 6 147 989 53 

Landjuweel 5

3905 PE - Veenendaal

 

OTHER CONTACT INFORMATION

Reply
Martin Winkler responded on 19 Aug 2013 5:52 AM

Thanks a lot!

Reply
Martin Winkler responded on 19 Aug 2013 6:23 AM

If you want to disable UAC (reason behind problem), see chapter "To disable Admin Approval Mode" in technet.microsoft.com/.../cc709691(WS.10).aspx

Reply
Dwain responded on 9 Jan 2014 1:49 PM

I seem to have the same issue (blank debugger) with AX 2009 .. and running as administrator does not work. Has anyone found the cause? I have uninstalled and installed to no avail. It has to be something with my PC as when I remote to another machine I don't have the issue.

Reply
Gvk responded on 21 Jan 2014 11:46 PM

Hi All,

when I am applying the debugger, getting blank screen .

please tell me the solution

Thank you.

Reply
Suggested Answer
Tommy Skaue responded on 5 Feb 2013 2:49 PM

I believe if you are debugging code that is running in .Net, you need to make sure the folder containing the source files is filled up. Not sure if this happens when the AOS starts, or of you actually need to run a CIL-compile for it to be filled. The source folder is located under X:\Program Files\Microsoft Dynamics AX\60\Server\AOS_ID\bin\XppIL\source

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Reply
Suggested Answer
UMESH PANDIT responded on 26 Nov 2014 8:55 AM

Hi Team,

To use the debugger, users must belong to the Microsoft Dynamics AX Debugging Users local group on the computer. The person who installed the debugger is automatically added to this group.

Also Note that If you added , then before using an Sign out /log out and sign in /log in is must.

You can run debugger and AX as run as administrator.

--

Thank you
Note - This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft.
Reply