Question Status

Verified
MarioZG asked a question on 26 Aug 2014 4:16 PM

Hi,


CRM 2013 SP1. vanilla system. I have created simple workflow generating email, with "record URL (dynamic)" in body. Unfortunately system generates this url, without organization name, which make it useless for multi-org deployments. Tried on account and opportunity to make sure its not entity depended issue. Is this a bug or am i missing something?


Thanks,

Mario

Reply
Suggested Answer
Corrie Rands responded on 26 Aug 2014 5:15 PM

The "record URL (dynamic)" must be used in conjunction with the hyperlink button. When you are in the template just click on the hyperlink button and then user dyanmic URL.

 

Reply
MarioZG responded on 27 Aug 2014 1:26 AM

I have tried both - just put it as plain text, or use in hyperlink as you have suggested. None of them contains organisation name :/

Reply
Luke Adams responded on 28 Aug 2014 9:20 PM

Have exactly the same problem. 

The URL that is generated does not include the Organisation name, and hence when clicked by the recipient will not open the record in question (this is irrespective of if it is created from the add hyper link button or using Record URL from the dynamic fields dropdown).  Works fine in CRM online where there is no Organisation name component to the URL.

 

LA

Reply
Daniel Bruckhaus responded on 2 Sep 2014 8:33 AM

Hi there!

Any Solutions yet?

We have the same Problem with a CRM Dialog....

Kind regards.
Daniel

Reply
Saravanakumar VE responded on 2 Sep 2014 8:52 AM

Below link may help you. Follow the steps

www.magnetismsolutions.com/.../Record_Hyperlinks_Available_in_Dynamics_CRM_2011_Workflows.aspx

Saravanakumar.VE

Reply
Nina Peneva responded on 10 Sep 2014 8:00 AM

Hi all,

I am sorry to hear that you run into this issue. Can you please provide us a particular example of the setting of the record in the workflow definition and the generated URL as a result. Please also specify the affected CRM Version.

Thank you for using Microsoft Dynamics CRM Community.

Nina Peneva

Microsoft Dynamics CRM

Follow EMEA Microsoft Dynamics CRM Support on Twitter @MSDynCRMSupport!
Reply
MarioZG responded on 13 Sep 2014 8:15 AM

Hi Nina,

First screenshot is how email is configured, second one presents generated email. Underlined are bits where I would expect organization name to be present.

Workflow itself is straightforward - just create email with template below.

Thanks a lot for looking into this!

CRM 2013, SP1

Screenshot 2

Reply
RP@Isd responded on 15 Sep 2014 4:50 PM

We are experiencing the same issue with a multi-org, on-premise 2013 implementation. Any information to resolve this issue would be helpful. We had this functionality in CRM 2011 and our users are expecting for it to be available when their applications are migrated to 2013.

Thanks

Reshma

Reply
MerlinNZ responded on 15 Sep 2014 7:03 PM

Hi Nina,

We are experiencing the same problem even with a single organization (On-Premise).

Are there any resolve for this issue?

Regards,

Reply
Suggested Answer
Nina Peneva responded on 17 Sep 2014 10:26 AM

Hi all,

many thanks for your posts and the information. I am sorry to hear that you are experiecing this issue.

I can confirm that in the meantime the same issue was already reported to CRM Technical Support and our Escalation Team is currently investigating it in detail.

I will update the thread once we have more information on the issue.

We appreacite your patience and collaboration going forward.

Thank you for using Microsoft Dynamics CRM Community.

Regards,

Nina Peneva

Support Engineer

Microsoft Dynamics CRM

Follow EMEA Microsoft Dynamics CRM Support on Twitter @MSDynCRMSupport!
Reply
Suggested Answer
Nina Peneva responded on 22 Sep 2014 6:02 AM

Hi all,

I would need your kind assistance going forward. Can you please send me a quick email to crmuser14@outlook.de with your company name, contact person and email address so that we can track you as affected by this issue customers. This will help us prioritize the fix. Many thanks for your kind collaboration in advance and for using Microsoft Dynamics CRM Community.

Important: please note that the provided email crmuser14@outlook.de will be monitored in the next 2 weeks only. I will appreciate your quick response.

Regards,

Nina Peneva

Support Engineer

Microsoft Dynamics CRM

Follow EMEA Microsoft Dynamics CRM Support on Twitter @MSDynCRMSupport!
Reply
Suggested Answer
Nina Peneva responded on 29 Sep 2014 11:07 AM

Hi all,

just a kind reminder: Can you please send me a quick email to crmuser14@outlook.de with your company name, contact person and email address so that we can track you as affected by this issue customers. This will help us prioritize the fix.

To date, we've got only one response.

Many thanks for your kind collaboration in advance and for using Microsoft Dynamics CRM Community.

Nina Peneva

Support Engineer

Microsoft Dynamics CRM

Follow EMEA Microsoft Dynamics CRM Support on Twitter @MSDynCRMSupport!
Reply
Pince responded on 15 Oct 2014 1:26 PM

Are there any updates to this issue?  I am also experiencing this issue in a multi-organization on-premise deployment.

Thanks,

Reply
Verified Answer
Nina Peneva responded on 23 Oct 2014 11:50 AM

Hi all,

I am happy to inform you that the issue "Dialog missing organization name in hyperlink if not default organization" has been addressed. The fix will be included in CRM 2013/SP1 UR2, which is per current information expected to be released in January.

If you require the fix earlier than in January, you can log a Support Case to get a Critical On Demand (COD) fix for the issue. Please note that in comparison to the full testing we are doing for an official UR, we are only able to do a reduced set of testing for a COD fix. By logging a case with us, we will be able to track the customers who got the COD in case if any issues identified. I would like to highlight that you will not be charged for the Support Request to get the COD as this is related to a confirmed design mistake.

The ones of you, who contacted us directly via the provided for this issue email has been personally updated about the fix via email.

Thank you everyone for your patience and your kind collaboration.

Regards,

Nina Peneva

Support Engineer

Microsoft Dynamics CRM

Follow EMEA Microsoft Dynamics CRM Support on Twitter @MSDynCRMSupport!
Reply
MarioZG responded on 25 Oct 2014 8:36 AM

thanks a lot Nina!

Reply
Verified Answer
Nina Peneva responded on 23 Oct 2014 11:50 AM

Hi all,

I am happy to inform you that the issue "Dialog missing organization name in hyperlink if not default organization" has been addressed. The fix will be included in CRM 2013/SP1 UR2, which is per current information expected to be released in January.

If you require the fix earlier than in January, you can log a Support Case to get a Critical On Demand (COD) fix for the issue. Please note that in comparison to the full testing we are doing for an official UR, we are only able to do a reduced set of testing for a COD fix. By logging a case with us, we will be able to track the customers who got the COD in case if any issues identified. I would like to highlight that you will not be charged for the Support Request to get the COD as this is related to a confirmed design mistake.

The ones of you, who contacted us directly via the provided for this issue email has been personally updated about the fix via email.

Thank you everyone for your patience and your kind collaboration.

Regards,

Nina Peneva

Support Engineer

Microsoft Dynamics CRM

Follow EMEA Microsoft Dynamics CRM Support on Twitter @MSDynCRMSupport!
Reply
Suggested Answer
Corrie Rands responded on 26 Aug 2014 5:15 PM

The "record URL (dynamic)" must be used in conjunction with the hyperlink button. When you are in the template just click on the hyperlink button and then user dyanmic URL.

 

Reply
Suggested Answer
Nina Peneva responded on 17 Sep 2014 10:26 AM

Hi all,

many thanks for your posts and the information. I am sorry to hear that you are experiecing this issue.

I can confirm that in the meantime the same issue was already reported to CRM Technical Support and our Escalation Team is currently investigating it in detail.

I will update the thread once we have more information on the issue.

We appreacite your patience and collaboration going forward.

Thank you for using Microsoft Dynamics CRM Community.

Regards,

Nina Peneva

Support Engineer

Microsoft Dynamics CRM

Follow EMEA Microsoft Dynamics CRM Support on Twitter @MSDynCRMSupport!
Reply
Suggested Answer
Nina Peneva responded on 22 Sep 2014 6:02 AM

Hi all,

I would need your kind assistance going forward. Can you please send me a quick email to crmuser14@outlook.de with your company name, contact person and email address so that we can track you as affected by this issue customers. This will help us prioritize the fix. Many thanks for your kind collaboration in advance and for using Microsoft Dynamics CRM Community.

Important: please note that the provided email crmuser14@outlook.de will be monitored in the next 2 weeks only. I will appreciate your quick response.

Regards,

Nina Peneva

Support Engineer

Microsoft Dynamics CRM

Follow EMEA Microsoft Dynamics CRM Support on Twitter @MSDynCRMSupport!
Reply
Suggested Answer
Nina Peneva responded on 29 Sep 2014 11:07 AM

Hi all,

just a kind reminder: Can you please send me a quick email to crmuser14@outlook.de with your company name, contact person and email address so that we can track you as affected by this issue customers. This will help us prioritize the fix.

To date, we've got only one response.

Many thanks for your kind collaboration in advance and for using Microsoft Dynamics CRM Community.

Nina Peneva

Support Engineer

Microsoft Dynamics CRM

Follow EMEA Microsoft Dynamics CRM Support on Twitter @MSDynCRMSupport!
Reply