Question Status

Verified
Carole Collins asked a question on 2 Feb 2012 8:12 AM

We cloned our production system and ran the scripts to change the SQL instance name and updated teh ODBC connection but when we launch the server it is still looking at the production server name.  How can we change this name?

Reply
Verified Answer
Richard Wheeler responded on 2 Feb 2012 8:39 AM

Assuming when you say launch the server you mean you are on the newly cloned server and launched the GP client on that server, please make sure you have changed the DSN on that server to point to the cloned server not the original. You may want to drop the DSN altogether just to make sure plus if the cloned server is 64 bit remember to do this using the 32 bit ODBC adminstrator. It sounds like your ODBC DSN is still pointing to the orignal server.

Richard E. Wheeler 2013 and 2014 MVP

Member Microsoft Academic Alliance

www.rbsolutions.com Revered Business Solutions Ballston Lake, NY  518-877-0763 x10

Reply
Verified Answer
Leslie Vail responded on 2 Feb 2012 8:56 AM

If you actually want to change of the SQL Server itself, try this:

 

1. Open SQL Server Management Studio and click New Query.

2. Type Select @@ServerName to find out the current server name. In our example, we’ll be changing the server name from RKF to REH.

3. Next, type sp_dropserver ‘RKF’

4. You are now ready to add the correct name by typing sp_addserver ‘REH’.

5. Stop sql server and the sql server agent by opening a command prompt and typing net stop mssqlserver.

6. Restart SQL server by typing net start msssqlserver.

7. Restart SQL server agent by typing net start sqlserveragent.

8. Click New Query in SQL Server Management Studio and type select @@servername to verify everything is correct and you have successfully changed the sql server name.

Kind regards,

Leslie

Leslie Vail, CPA, MVP, MCT, MCITP, MCP, MCITS
ASCI, Inc.    *    PO Box 600965   *   Dallas, TX 75360    *   972-814-8550   *   leslievail@earthlink.net

Reply
Carole Collins responded on 2 Feb 2012 12:01 PM

We did change the SQL server name but when we launch, the server name says 'Dynamics GP 2010' and the error reads: 'Your attempt to log in to the servaer failed becasue an unknown error occurred when the user ID and password were being verified. Attempt to log in again.  we changed the name of the SQL server to test-csogp2010db.  How can we get the ID to point to this new name?

Reply
Verified Answer
Mohammad Daoud responded on 6 Feb 2012 12:21 AM

Two things to verify:

1. Make sure you are using SA user, as all other accounts will not work until doing password reset at the application level.

2. Make sure you changed the ODBC to point into the new server.

*** If my answer resolved you issue, please verify the answer to make it easy for other users who has the same case ***

Regards,

 

Mohammad R. Daoud MVP-MCT

Have you seen the GP Excel Paste yet? http://di.jo/GPExcelPaste.aspx

Reply
Verified Answer
Vikas Gupta responded on 6 Feb 2012 7:52 AM

we can change the server name from administrative tools-->>ODBC-->>System DSN-->>Dynamics GP -->> Click on Configure and then we change the setting for server and other settings also.

Thanks and Regards

Vikas Gupta

vikasgupta.gp@hotmail.com

Reply
Verified Answer
Richard Wheeler responded on 2 Feb 2012 8:39 AM

Assuming when you say launch the server you mean you are on the newly cloned server and launched the GP client on that server, please make sure you have changed the DSN on that server to point to the cloned server not the original. You may want to drop the DSN altogether just to make sure plus if the cloned server is 64 bit remember to do this using the 32 bit ODBC adminstrator. It sounds like your ODBC DSN is still pointing to the orignal server.

Richard E. Wheeler 2013 and 2014 MVP

Member Microsoft Academic Alliance

www.rbsolutions.com Revered Business Solutions Ballston Lake, NY  518-877-0763 x10

Reply
Verified Answer
Leslie Vail responded on 2 Feb 2012 8:56 AM

If you actually want to change of the SQL Server itself, try this:

 

1. Open SQL Server Management Studio and click New Query.

2. Type Select @@ServerName to find out the current server name. In our example, we’ll be changing the server name from RKF to REH.

3. Next, type sp_dropserver ‘RKF’

4. You are now ready to add the correct name by typing sp_addserver ‘REH’.

5. Stop sql server and the sql server agent by opening a command prompt and typing net stop mssqlserver.

6. Restart SQL server by typing net start msssqlserver.

7. Restart SQL server agent by typing net start sqlserveragent.

8. Click New Query in SQL Server Management Studio and type select @@servername to verify everything is correct and you have successfully changed the sql server name.

Kind regards,

Leslie

Leslie Vail, CPA, MVP, MCT, MCITP, MCP, MCITS
ASCI, Inc.    *    PO Box 600965   *   Dallas, TX 75360    *   972-814-8550   *   leslievail@earthlink.net

Reply
Verified Answer
Mohammad Daoud responded on 6 Feb 2012 12:21 AM

Two things to verify:

1. Make sure you are using SA user, as all other accounts will not work until doing password reset at the application level.

2. Make sure you changed the ODBC to point into the new server.

*** If my answer resolved you issue, please verify the answer to make it easy for other users who has the same case ***

Regards,

 

Mohammad R. Daoud MVP-MCT

Have you seen the GP Excel Paste yet? http://di.jo/GPExcelPaste.aspx

Reply
Verified Answer
Vikas Gupta responded on 6 Feb 2012 7:52 AM

we can change the server name from administrative tools-->>ODBC-->>System DSN-->>Dynamics GP -->> Click on Configure and then we change the setting for server and other settings also.

Thanks and Regards

Vikas Gupta

vikasgupta.gp@hotmail.com

Reply