Question Status

Unanswered
ewills asked a question on 29 Apr 2012 1:24 PM

 

Hi, I am getting an error while trying to deploy the SSRS reports in GP 2010. I configured the SSRS Report Server - it uses "Local System" service account. I used the Admin user account to log in the database server and also uses the windows credentials as authentication type.  I tried with SQL authentication and it was able to successfully configure the Report Server database. As an alternative, I try to use a Domain User Account, couldn't succeed.  Report Server Location http://SERVER:80/ReportServer_DYNAMICSGP

In order to use a Domain user account, what are the minimum permissions required? 

Any idea why I am getting this error? 

 

Reply
Carl Holzhauer responded on 30 Apr 2012 8:00 AM

I've always ran SQL services as a domain member for this very reason; There's something about the way SQL server works in that if you want to connect across a domain, you need to run as domain\user instead of a local account

Reply
ewills responded on 30 Apr 2012 8:25 AM

Hi Carl, I tried to create a domain user account and added permission to SQL Server database but when I tried to add as a service account in the RSConfiguration wizard, i am getting error as "the user doesn't have access to location where the reports will be deployed". I am not sure what permission that I need to set for this user?

Reply
Carl Holzhauer responded on 30 Apr 2012 8:31 AM

You need to use a user that has deploy access on the SRSS server   (Log into the reports server to set it)

Reply
ewills responded on 30 Apr 2012 8:57 AM

Hi, I tried that and still no luck. 

 

I was able to connect to the report server database 

 

but still I am getting the same error "you don't have security access to the location where you want the report to be deployed" 

I also gave administrator permission to the domain user and tried but no luck. what could be the issues? 

 

Reply
ewills responded on 30 Apr 2012 9:18 AM

i added the permissions for that user in the report server. but still no luck. What am I missing here?  

Reply
Rob Bernhardt responded on 3 May 2012 6:50 AM

ewills,

What version of SRS are you using?  GP 2010 is compatibile with the following versions of SRS: 

  • SQL Server Reporting Services for SQL Server 2005 SP 2 or later Standard or Enterprise Edition
  • SQL Server 2008 with any service pack Standard or Enterprise Edition or SQL Server 2008 R2 with any service pack Standard or Enterprise Edition.

 

Thanks

Rob

Rob Bernhardt [MSFT]

This posting is provided "AS IS" with no warranties, and confers no rights.

Reply
Charles Ray responded on 17 Jul 2012 7:37 AM

I'm having the same issue with SQL 2012 Express on Server 2008R2.  GP is a new install of 2010 with SP3.  I have tried a domain user, network service, the new ReportService account, and a domain admin, all with the same error - this is while setting up new companies in Dynamics Utilities (running as administrator - UAC is OFF).

I have even gone into the actual folder structure (SSRS Folder permissions are already set to everything for everyone, ditto Site Security) and forced full permissions for the folder and subfolders.

Any help is appreciated!

Reply
Carl Holzhauer responded on 17 Jul 2012 7:43 AM

I don't think you're able to use SQL Express

Reply
Charles Ray responded on 17 Jul 2012 8:30 AM

Carl, unfortunately you appear to be correct.  I just checked the Microsoft System Specs, and it states SQL 2012 Express is supported for all but Analysis Cubes - however I did also find at least one Blog post on SQL 2008R2 SSRS which said something to the effect of 'If you're using SSRS on SQL Express, don't bother trying'.  I would have thought with no caveats in the official GP System Specs, it would work.  Thanks for the reality check!

Reply
Charles Ray responded on 17 Jul 2012 8:34 AM

EWills, looking through this post, I saw that you set site permissions, but did you set folder permissions (from the bar on the Home page)?

Reply