Question Status

Suggested Answer
Ann Duszkiewicz asked a question on 31 Jul 2014 10:33 AM

When releasing batches in GL I receive System error 6201 : Report execution failed error 56029. Error printing report.  The table  'GLTran' could not be found. 

This is only happening on one workstation.  It is a Windows 8 workstation. 

We are also receiving another error when releasing any other batches (AR, AP and a second error in GL) Failed to retrieve data from database.  Error in File 01acctdi (the account distribution report).

I have this fixed on all other workstation but the same fixes do not work on the windows 8 workstation.  Any ideas?

Reply
Ann Duszkiewicz responded on 31 Jul 2014 10:34 AM

PS We recently upgraded from Dynamics 7 FP1 to Dynamics 2011 FP1

Reply
Ann Duszkiewicz responded on 31 Jul 2014 11:41 AM

Ok So Removing the ODBC sql dsn files for the system and application database resolved the 1st issue but I am still having an issue with the 01AcctDI - failed to retrieve data from database.  I checked the user's rights - he is an admin so he has initialize for everything.

Reply
Mark Asmus responded on 30 Aug 2014 8:53 PM

Ann,

Can you paste in the exact error?  That is strange that it only seems to be the one report on the one machine.   Can the same user run the report without error from another machine?

Mark
Technical Support Engineer

**This posting is provided "AS IS" with no warranties and confers no rights.

Reply
Theresa Coleman responded on 4 Sep 2014 12:30 PM

I have a couple of workstations that don't print the 01AcctDi report when printing batch control reports from all modules (AP, AR, PO).  This problem started when we upgraded to SP1.  We just upgraded to SP2 and it is still happening.  We are all on Windows 7.  The error message received on one workstation is:

System Message 6201

Report execution failed.  Error = 56029

Error Printing Report

Failed to retrieve data from the database.

Details:  [Database Vendor Code: 229]

Failed to retrieve data from the database.

Error in File 01acctdi {D89BC91D-5DD4-45D2-B449-0BDDE4B59B30}.rpt:

Failed to retrieve data from the database.

Details:  [Database Vendor Code: 229].

 

Has anyone figured out a solution to this problem?

Reply
Suggested Answer
Rick Kerns responded on 4 Sep 2014 4:43 PM

Ann,

Does this workstation happen to have the FRx client installed on it?  There is a hot fix needed for SL 2011 where FRx is installed.  This hot fix corrects some triggers needed by FRx.  While the hot fix does not directly sound like your issue, I found that, without it, clients would randomly, it seems, get situations where SQL would not return data.  You want to download and install B2551470_FRx_SL2011_93Fix whenever you have SL 2011 and FRx triggers have been set.  Not sure this will correct your problem but give it a try if you have not.

Reply
Suggested Answer
Rick Kerns responded on 4 Sep 2014 4:43 PM

Ann,

Does this workstation happen to have the FRx client installed on it?  There is a hot fix needed for SL 2011 where FRx is installed.  This hot fix corrects some triggers needed by FRx.  While the hot fix does not directly sound like your issue, I found that, without it, clients would randomly, it seems, get situations where SQL would not return data.  You want to download and install B2551470_FRx_SL2011_93Fix whenever you have SL 2011 and FRx triggers have been set.  Not sure this will correct your problem but give it a try if you have not.

Reply