Question Status

Unanswered
Kaci Rumelhart asked a question on 1 May 2012 9:25 AM

We recently upgraded to Microsoft Dynamics SL 2011 and are having issues with Business Portal. The first issue I've found is that there is no Business Portal Administration section in Business Portal. I am logged in as admin and I do not see where to add users or roles. I've added the new users to the groups and they now get an "unexpected error has occurred" error. Only new users are getting this message while the existing users can access Business portal.

The version of Business Portal is 5.1.3411.0

I also get the following message in the event log:

The description for Event ID 0 from source MicrosoftBusinessFrameworkLog cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

UserManager VerifyUser 262 GENOVA\mryork is not in UserWindowsIdentity table.

The message resource is present but the message is not found in the string/message table

Any help would be appreciated.

Thanks,
Kaci

Reply
Carolyn Kolpien responded on 3 May 2012 12:26 PM

Hello Kaci,

You should find the Business Portal Administration section where you can add Users, set Data Permissions and add Roles by clicking on Site Actions | Site Settings.  The Business Portal Administration section is in the middle column at the bottom.

What action are you taking that generates the error?  Maybe this error was incurred during a failed attempt to install.  Perhaps the user trying to install BP was not in the User Windows Identity table.  It sounds like you now have it installed since you are looking for the Business Portal Administration menu.

Carolyn

Technical Support Engineer

**This posting is provided "AS IS" with no warranties and confers no rights.

Reply
Bill Fry responded on 13 Jun 2012 9:03 AM

I get the same Event Viewer information as above.  The account it is referencing is a SharePoint service account that I do not want in the UserWindowsIdentity table, but the event fills the event viewer.  How can I stop this from repeating in the event viewer?

Reply
Mike Scott responded on 9 Jan 2014 1:17 PM

I would like to know the answer to this as well since we are seeing this:

UserManager  VerifyUser  262  NT AUTHORITY\LOCAL SERVICE is not in UserWindowsIdentity table.

Reply
Carolyn Kolpien responded on 9 Jan 2014 1:34 PM

Scott,

Maybe try the following steps:

1 - Login as the admin

2 - Go to site actions -> site settings

3 - under business portal administration, click on user

4 - See if the "NT AUTHORITY\LOCAL SERVICE " user is in the list of users. If they are not, try adding them.

If they ARE in the list, select them. Then on the "description" tab, what shows as the Domain\Alias?

If it's populated, is it correct (matches NT AUTHORITY\LOCAL SERVICE)? If it's blank, you may need to delete this user and re-add them.

Carolyn

Technical Support Engineer

**This posting is provided "AS IS" with no warranties and confers no rights.

Reply