Question Status

Suggested Answer
Xcarlos asked a question on 24 Aug 2012 7:52 AM

SL 7. I just close year 2011. After that a create a new account and  it is "Active". but when i try to do a new gl detail it doesn't show on the F3 pop up  list.  What could i be missing?

thanks

Carlos
Produce Business

Reply
Suggested Answer
LBrewster responded on 20 Sep 2012 11:39 AM

Guess what - I found it.  There was a company in the domain table that didn't exist in the company table.  Once I got rid of it (this company was never used) and rebuilt triggers, and then edited the COA table, saved and changed it back and saved again - I could see the new accounts in the PV again.  Kind of a bummer Microsoft is still charging me for the incident even though they didn't figure it out...

Reply
Suggested Answer
Jane R. responded on 28 Feb 2014 1:22 PM

Just ran into this problem and Carolyn's suggestion worked for me .

"Depending on your authentication method, it will also update some views in the application database.   If the account isn't in the Acctxref table in the system database, it won't show in the PV list in the Journal Transactions screen.  If you find it is missing from Acctxref, usually you just need to make a small change in the Chart of Accounts maintenance screen, save the change, then undo that change and save again.  The Acctxref table should be refreshed."

Thanks!

Reply
Carolyn Kolpien responded on 28 Aug 2012 6:42 AM

Hi Carlos,

Are you trying to find the account in the Journal Transactions screen?  When you F3 in that screen, which PV list shows?  Is it the Master Account List or is it Account List?  If it is Account List, then you have Validate Account Subaccount checked in GL Setup.  Since you have that option checked, you would need to set up Account/Subaccount combinations so that it will show in the PV list.

Please let me know which PV comes up when you F3 in the Journal Transactions screen.  Thanks.

Carolyn

Technical Support Engineer

**This posting is provided "AS IS" with no warranties and confers no rights.

Reply
Xcarlos responded on 30 Aug 2012 9:53 AM

Hello Carolyn. It's the 01.010.00 journal transactions screen.  In the detail area. the F3 shows the gltran.acct Field. The PV sows "acctxref_acct", "bcompany.cpnycoa"; 0; 0; 0; 0,  The Validate accoutnt Subaccount is unchecked.  5 days after i posted this, the account showed, What i did was to print preview a Trial Balance and a Detail General ledger report.  .  Is there a proceess between the Account List and the Master Account List?  Where can i see them on SQL?

Reply
Carolyn Kolpien responded on 31 Aug 2012 7:22 AM

Hello Xcarlos,

If you validate account subaccount combinations in GL Setup, you will see the Account List.  If you do not, you will see the Master Account List.

When you added the account, did you use the Chart of Accounts Maintenance screen?  Or did you use another process?  When you add an account in Chart of Accounts maintenance, it should update the Account table in the application database, and the AcctXref table in the system database.  Depending on your authentication method, it will also update some views in the application database.   If the account isn't in the Acctxref table in the system database, it won't show in the PV list in the Journal Transactions screen.  If you find it is missing from Acctxref, usually you just need to make a small change in the Chart of Accounts maintenance screen, save the change, then undo that change and save again.  The Acctxref table should be refreshed.

Does this answer your question?

Carolyn

Technical Support Engineer

**This posting is provided "AS IS" with no warranties and confers no rights.

Reply
LBrewster responded on 18 Sep 2012 4:16 PM

Hi Carolyn - I am running into the same issue and I tried all the solutions you mentioned above.  I also rebuild the triggers, etc and I still can't see the account.  I also checked in standard mode given I know the JE screen is customized.  Any other ideas?  (PS. we are NOT using acct/sub validation and the PV is the master COA; we added the account to the master company in the COA maintenance screen).  Thanks for any help!

Reply
Carolyn Kolpien responded on 20 Sep 2012 11:22 AM

Hi LBrewster,

Are you in a SQL or Windows Authenticated database?  Maybe check the following tables in SQL Server Management Studio and see in which table/view the account is missing:

Application Database:

Select * from account where acct = 'xxxx'

Select * from vs_acctxref where acct = 'xxxx'

System Database:

Select * from acctxref where acct = 'xxxx'

Make sure the account is Active.  

Let me know what you find.

Carolyn

Technical Support Engineer

**This posting is provided "AS IS" with no warranties and confers no rights.

Reply
Suggested Answer
LBrewster responded on 20 Sep 2012 11:39 AM

Guess what - I found it.  There was a company in the domain table that didn't exist in the company table.  Once I got rid of it (this company was never used) and rebuilt triggers, and then edited the COA table, saved and changed it back and saved again - I could see the new accounts in the PV again.  Kind of a bummer Microsoft is still charging me for the incident even though they didn't figure it out...

Reply
Suggested Answer
Jane R. responded on 28 Feb 2014 1:22 PM

Just ran into this problem and Carolyn's suggestion worked for me .

"Depending on your authentication method, it will also update some views in the application database.   If the account isn't in the Acctxref table in the system database, it won't show in the PV list in the Journal Transactions screen.  If you find it is missing from Acctxref, usually you just need to make a small change in the Chart of Accounts maintenance screen, save the change, then undo that change and save again.  The Acctxref table should be refreshed."

Thanks!

Reply