Dynamics CRM V9 connection Error in Pluging/Console or Custom Web Application/Report Viewer in VS
Views (1843)
Recently faced a strange issue in CRM v9 while connecting to Org Service. It was perfectly working before last night. Below the issues faced many issues in different scenarios. Am trying to consolidate all here . If any one faces the any of the below issue then try the solution given below.
ISSUES:
Not able to login Plugin registration tool (Keep popping up for Credentials)
Not able to see custom entites in Plugin Registration tool
Connection to CRM from Custom Web application & console failed
Can able to retrive data in DataSet in Report rdl but not able to Preview
ROOT CAUSE:
Its all because of the latest update in the Microsoft TSL(Transport Security Layer) Protocol in SDK assemblies..Microsoft allowed the TSL connection 1.0 and 1.1 for the browsers or client to connect the CRM org.Now Microsoft will support only TSL 1.2 or above going forward(Reference) . If you are connecting your org with the old version of plugin registration tool , then you may face this issue
HOW TO IDENTIFY:
Use fiddler to check the your server request TSL Version. Install fiddler https://www.telerik.com/download/fiddler
SOLUTION:
1.For Plugin Issue: Update latest SDK from the Plugin Registration Tool
or Download tools from NuGet2.For Report: Uninstall Report Authoring Extension and install the latest.(Make sure Installed dll has the latest SDK)
3.For Custom Application or Console App : Include the below reference to your project(to global config file the line before where your client credentials is configured) and change the .Net framework to 4.6.1 and rebuild
"ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls11 | SecurityProtocolType.Tls12"
4. Modify using TSL to 1.2 through Fiddler
This was originally posted here.
*This post is locked for comments