web
You’re offline. This is a read only version of the page.
close
Skip to main content

Notifications

Announcements

No record found.

Community site session details

Community site session details

Session Id :
Microsoft Dynamics CRM (Archived)

Sending email to multiple recipients using Dynamics Values in CRM Workflow

(0) ShareShare
ReportReport
Posted on by

I am sending emails to multiple recipients using Dynamic Values, but the system is not sending email to all the recipients instead it is sending only to the first recipient in the list Here is what i have in the TO Field "{Solution Center(Owning Business Unit (Business Unit));General Manager(Owning Business Unit (Business Unit));Created By(Opportunity);Owner(Opportunity);Owning User(Opportunity)}"

*This post is locked for comments

I have the same question (0)
  • Suggested answer
    Community Member Profile Picture
    on at

    You should use team-based recipients lists rather than user-based lists in order to comply with best practices for maintaining your CRM data. Also, make sure that all of your recipients have valid email addresses.

    Please vote for my answer if it helped you with your problem.

  • Community Member Profile Picture
    on at

    But how to do this, as in the static email search box only users are available, we cant add teams there.

    Please suggest

  • Verified answer
    Community Member Profile Picture
    on at

    I would recommend importing this custom solution created by Jason Lattimer: crm2011internalemail.codeplex.com. It will enable you to send emails to business unit, team, and security role.

  • thomasled2 Profile Picture
    on at

    Hello Mudassar. I am having this same issue and was wondering if you have a resolution to it?

    I think that the way to resolve it may be to add each dynamic value to the email separately instead of all at once. Meaning, choose one dynamic value to put into the 'To' list, click ok, clear that out, and then enter the second dynamic value and so on.

    I have not tested that approach out yet. Was hoping to find the answer first, but that is my thought.

  • Suggested answer
    Community Member Profile Picture
    on at

    Here is the solution provided by MS Support

    ISSUE:

    =====

    When sending an e-mail to multiple users, using Dynamic Values, only one person is receiving the e-mail.

     

    CAUSE:

    ======

    The Dynamic Value should be written in the form {Recipient 1} {Recipient 2} .. {Recipient n} and it was being used like {Recipient 1 ; Recipient 2 ; ... ; Recipient n} which only outputs 1 value

     

    RESOLUTION:

    ============

    To solve the problem the customer changed the "To" field. Where before there were the Dynamic Values:

     

    {SCM(Owning Business Unit (Business Unit))} {GM(Owning Business Unit (Business Unit))} {Created By(Opportunity)} {Owner(Opportunity)} {Owning User(Opportunity)}

     

    It was replaced with the new Dynamic Values:

     

    {SCM(Business Unit (Business Unit))} {GM(Business Unit (Business Unit))} {Created By(Opportunity)} {Owner(Opportunity)} {Owning User(Opportunity)}

     

    It should be noted that during the troubleshooting of this case we identified a new issue, because the Dynamic Value "Solution Center(Owning Business Unit (Business Unit))" wasn't having any output. We corrected it to "SCM(Business Unit (Business Unit))" to reference to the correct Business Unit Record and have the expected output.

  • Community Member Profile Picture
    on at

    hi mudassar can u pls explain in some more brief this scenario.

    i want to send a mail to group of people as u said how i have to configure this in workflow.

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Responsible AI policies

As AI tools become more common, we’re introducing a Responsible AI Use…

Neeraj Kumar – Community Spotlight

We are honored to recognize Neeraj Kumar as our Community Spotlight honoree for…

Leaderboard > 🔒一 Microsoft Dynamics CRM (Archived)

#1
SA-08121319-0 Profile Picture

SA-08121319-0 4

#1
Calum MacFarlane Profile Picture

Calum MacFarlane 4

#3
Alex Fun Wei Jie Profile Picture

Alex Fun Wei Jie 2

Last 30 days Overall leaderboard

Featured topics

Product updates

Dynamics 365 release plans