Skip to main content

Notifications

Announcements

No record found.

Business Central forum
Suggested answer

Object in Web Service not Showing in Power BI

Posted on by 10
Hi,
 
I am trying to published 'Item List' page object in web service and use it in Power Bi. But even though the 'Published' checkbox is ticked, it is not showing up in Power Bi. Object Id is 31. But if i published another page with object Id 32, it will show up in power bi. Any Ideas? 
 
I have also tested the the Odata URL in postman, object Id 31 (Item List page) is getting error 404 Not found. But object Id 32 (Item Lookup Page) is getting a response in postman.
 
Thanks 
 
  • Tiffany Profile Picture
    Tiffany 10 on at
    Object in Web Service not Showing in Power BI
    Hi Zhu,
     
    refreshed environment, issue is still there. Tried to delete object 31 from web service and add back in, still not showing up in PBI. 
     
    The weird thing is its showing up on yours and GR's PBI.
     
    Thanks
     
    Regards,
    Tiffany
  • Tiffany Profile Picture
    Tiffany 10 on at
    Object in Web Service not Showing in Power BI
    Hi Yun Zhu,
     
    How do you restart the environment?

    Edit: Ok, I found out how to restart, will try and see if this resolve the issue.
     
    Thanks
     
    Regards,
    Tiffany
  • Suggested answer
    YUN ZHU Profile Picture
    YUN ZHU 62,281 Super User on at
    Object in Web Service not Showing in Power BI
    Hi, I also tried it and didn't encounter this problem. This is a bit strange, If restarting the environment still doesn't solve the problem, you can submit a support ticket to Microsoft.
     
    Thanks
    ZHU
  • Tiffany Profile Picture
    Tiffany 10 on at
    Object in Web Service not Showing in Power BI
    Hi,
     
    That's strange because I am still getting the same issue here. Even in Power Bi its only showing object id 32.
     
     
     
     
     
    Thanks
  • gdrenteria Profile Picture
    gdrenteria 3,888 Super User on at
    Object in Web Service not Showing in Power BI
    hi
    I have tried it in version 24, and I do not experience your problem
     
    BR
    GR

Helpful resources

Quick Links

Can you answer this forum question?

You could make someone's day!

Community Newsletter - May 2024

Kudos to our community stars!

Community Spotlight of the Month

Kudos to Mohamed Amine Mahmoudi!

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 283,676 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 224,910 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,146

Featured topics

Product updates

Dynamics 365 release plans