Skip to main content
Business Central forum
Answered

Functionality not being updated in Production Env

editSubscribe (0) ShareShare
ReportReport
Posted on by 382

Hey community, 

I was working on sandbox environment (development env) of business central. I did a small customization using AL code on the sandbox environment and later manually installed it on the production environment. When I am updating that code file and again executing it on the sandbox environment it is being successfully executed but later when I am again manually installing it on the production environment it is not working and the previous code customization is displayed. Kindly tell me how can I manually update it again and again? or do I have to change environmentType: "Production"?

Categories:
  • Verified answer
    DAnny3211 Profile Picture
    DAnny3211 9,180 Super User on at
    RE: Functionality not being updated in Production Env

    hi

    look this

    learn.microsoft.com/.../devenv-how-publish-and-install-an-extension-v2

    DAniele

  • Verified answer
    pankaj.k Profile Picture
    pankaj.k 960 on at
    RE: Functionality not being updated in Production Env

    Hi

    Create new version of your extension and  publish on your Sandbox and do testing. once it done successfully.

    install the same extension file in the production environment.

    Note: Did Not try to change the Environment Type.

Helpful resources

Quick Links

What Motivates a Super User?

We know many of you visit the Dynamics 365 Community and Power Platform…

Demystifying Copilot with Georg Glantschnig…

Industry experts answer burning questions directly from our amazing Community…

Setting Up Knowledge Sources for Copilot…

Look at how configuring a comprehensive knowledge base is crucial…

Leaderboard

#1
Andre Arnaud de Calavon Profile Picture

Andre Arnaud de Cal... 283,066 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 222,585 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,138

Product updates

Dynamics 365 release plans