Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics SL forum
Suggested answer

System Message 10247

Posted on by 735

One of my users got the following while trying to release AR and GL batches: System Message 10247 The SQLNoWait can only be called after a Status call with StartProcess as the 1st parameter.  She tried again about 45 minutes later and all was good.  Any insights?

  • Suggested answer
    Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: System Message 10247

    Here is a very simple answer by Carolyn Kolpien Technical Support Engineer

    It did the job for my situation.

    Here is her answer.

    community.dynamics.com/.../87933

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: System Message 10247

    La solución que fue viable es entrar "Liberar la transacciones" y liberar la factura. Se encuentra en (Cuentas por pagar / Procesos / Liberar transacciones

    system-message-10247.png

    Estoy soluciono el problema con el cliente.

    Aplico para Dynamics SL 2015

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: System Message 10247

    Correction 

    AsyncDelay=1

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: System Message 10247

    I added the [Database Runtime]  AsynncDelay=1 to the Solomon.ini on the server. Unable to locate it on the client. But, a reboot corrected the issue.

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    Re: System Message 10247

    I updated the solomon.ini file on the server, but I cannot find the file on the user's workstation.  Is this because they do not use a TS environment to access SL?

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    Re: System Message 10247

    Thanks

    Chuck

  • Craig Silvestri Profile Picture
    Craig Silvestri 55 on at
    Re: System Message 10247

    Paige's and Butch's worked for me at our client....adjust solomon.ini

    [Database Runtime]

    AsynncDelay=1

  • Butch Adams Profile Picture
    Butch Adams 4,757 on at
    Re: System Message 10247

    Restarting SL always fixes it for me.

    Changing this line in Solomon.ini:

    [Database Runtime]

    AsynncDelay=1

    Is supposed to be a fix, but I have not been able to prove it yet since restarting the client makes the issue go away.

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    Re: System Message 10247

    Just got a call on this issue again today.  Any one have a concrete resolution?

  • Suggested answer
    Community Member Profile Picture
    Community Member Microsoft Employee on at
    Re: System Message 10247

    This happened at a client of mine. The resolution was to add the following to the Solomon.ini on the workstation and the server

    [Database Runtime]

    AsynncDelay=1

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 288,420 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,672 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans