Skip to main content
Business Central forum
Suggested answer

Permissions are not applied to user in effective permissions

editSubscribe (0) ShareShare
ReportReport
Posted on by 20

I've assigned a permissionset with permissions to a user, but they aren't applied in the effective permissions of the user.

It's an on prem system version 18.5.

The objects are a report and a codeunit of an extension which I've created.

The user has super permissions.

I've just tried different things:

I created a permissionset and assigned it to the user.

I assigned the permissionset to a user group and assigned that to the user.

The name of the permissionset has no special characters.

I made a logout and login. 

Has someone an idea? Could it be a licensing problem?

Categories:
  • Suggested answer
    YUN ZHU Profile Picture
    YUN ZHU 59,978 Super User on at
    RE: Permissions are not applied to user in effective permissions

    Just adding some info about Business Central On-Premises version

    Dynamics 365 Business Central Universal code initiative:

    https://yzhums.com/30559/

    Hope this helps as well.

    Thanks.

    ZHU

  • dav86 Profile Picture
    dav86 20 on at
    RE: Permissions are not applied to user in effective permissions

    It was a licensing problem. I changed the object ids and thant it worked.

Helpful resources

Quick Links

What Motivates a Super User?

We know many of you visit the Dynamics 365 Community and Power Platform…

Demystifying Copilot with Georg Glantschnig…

Industry experts answer burning questions directly from our amazing Community…

Setting Up Knowledge Sources for Copilot…

Look at how configuring a comprehensive knowledge base is crucial…

Leaderboard

#1
Andre Arnaud de Calavon Profile Picture

Andre Arnaud de Cal... 283,068 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 222,591 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,138

Product updates

Dynamics 365 release plans