SBX - Search With Button

SBX - Forum Post Title

Dynamics V9 Error NET Framework when trying to update plugin assembly

Dynamics 365 for Customer Service Forum

RominaARG asked a question on 8 May 2018 11:51 AM

Question Status

Verified

Hi everyone, 

V9 has been installed in our organization by MS about 1-2 months ago. We made customizations and everything was working fine, and we also could update some plugins. Recently (two weeks ago) MS has published some patches, we supposed nothing had changed. Now we have to make some changes in one plugin, so we updated the code and when we try to update the assembly, this is the error message we're getting. It's kind of weird because no matter the framework we change, there's still the error saying 'Now Microsoft Dynamics 365 requires the 4.X.X version of .NET Framework'. 

It is the error: 

Info: 8/5/2018 12:16:29 p. m. Connected To CRM Organization: 5b35bec7-28c8-4129-a1bf-30dab1f45258
Info: 8/5/2018 12:16:29 p. m. Version: 9.0.2.186
Info: 8/5/2018 12:16:30 p. m. Retrieved Assemblies From CRM
Error: 8/5/2018 1:15:10 p. m. Error Updating Assembly In CRM: Este ensamblado de complemento utiliza la versión <ASSEMBLY NAME>, Version=1.0.0.0, Culture=neutral, PublicKeyToken=1bf979a6cd13407c de .NET Framework. Actualmente Microsoft Dynamics 365 requiere la versión 4.6.1 de .NET Framework para los ensamblados de complemento. Vuelva a generar el ensamblado con .NET Framework versión 4.6.1 e inténtelo de nuevo.

Server stack trace:
at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at Microsoft.Xrm.Tooling.Connector.CrmServiceClient.Update(Entity entity)
at PluginDeployer.PluginList.UpdateCrmAssembly(AssemblyItem assemblyItem, CrmServiceClient client)
Error: 8/5/2018 1:15:28 p. m. Error Updating Assembly In CRM: Este ensamblado de complemento utiliza la versión <ASSEMBLY NAME>, Version=1.0.0.0, Culture=neutral, PublicKeyToken=1bf979a6cd13407c de .NET Framework. Actualmente Microsoft Dynamics 365 requiere la versión 4.6.1 de .NET Framework para los ensamblados de complemento. Vuelva a generar el ensamblado con .NET Framework versión 4.6.1 e inténtelo de nuevo.

Has anyone faced this issue before? 

Thanks in advance!

Reply
Tomas Prokop responded on 9 May 2018 2:37 PM
My Badges
Verified Answer

Hi,

have you tried to use 4.5.2 as a target framework in your plugin?

Reply
Juan Castillo responded on 9 May 2018 7:11 PM
My Badges
Verified Answer

Use .NET Framework Ver 4.5.2, works for me, thanks...

Reply
RominaARG responded on 10 May 2018 1:47 PM

Thanks to both of you!

Worked fine for me too!

Reply
Tomas Prokop responded on 9 May 2018 2:37 PM
My Badges
Verified Answer

Hi,

have you tried to use 4.5.2 as a target framework in your plugin?

Reply
Juan Castillo responded on 9 May 2018 7:11 PM
My Badges
Verified Answer

Use .NET Framework Ver 4.5.2, works for me, thanks...

Reply

SBX - Two Col Forum

SBX - Migrated JS