Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics CRM forum
Suggested answer

Import of solution failed without clear error

Posted on by 476

I'm trying to import a solution into production that is exported from the test environment. I'm receiving the error: "Import failed" on the solution, when 3/4 of the solutions seems to be processed. And no errors more. Also in the log file there is just one line from the solution with an error "Import failed". I tried several things to solve the problem:

  • I checked the solution XML
  • Tried removing possible problematic parts of the XML 
  • Tried removing possible conflicting parts in the target system before importing the solution
  • I tried to import the solution on the test environment itself; no problem
  • Timeout is not the problem, the solution is not so big

So now I'm one step away from setting up the production environment from scratch, so there can't be any conflicts. That will cost me a lot of time. But maybe one of you may have an interesting suggestion I could try. 

Thanks in advance!
Elowy.

  • Slowytech Profile Picture
    Slowytech 476 on at
    RE: Import of solution failed without clear error

    Hi Pranav,

    Thanks for your suggestions. The logfile doesn't show any errors, except for the "Import failed" at the solution line. I did import (deployed) the solution before, but it has been extended a lot in the meanwhile. And I also checked the suggestions in the article. Based on the suggestion of Goutam I tried to compare both solution xml's (last and second last). That works fine, but I didn't find the problem. The solution has been extended a lot since the last deploy.

    What I did to solve the problem was copying the total test environment to production. And importing the saved content on production again. That helped, but was definitely not the preferred solution...

    Lesson learned: Do a regular deploy so the differences between the last and second last deploy are not to big.

    Thanks for all your help,

    Elowy.

  • Suggested answer
    PranavShroti Profile Picture
    PranavShroti 4,508 on at
    RE: Import of solution failed without clear error

    Hi Elowy,

    I am afraid we will be needing more details to diagnose this issue. A logfile will be really helpfull. This is the first time you are trying to import the solution on this environment?

    Meahwhile you can check this post to get some clues.

    www.powerobjects.com/.../troubleshooting-solution-import-errors

    Regards,

    Pranav

    If found useful, please mark the answer as verified

  • gdas Profile Picture
    gdas 50,083 on at
    RE: Import of solution failed without clear error

    Hi Elowy,

    Is it managed solution or unmanaged solution?  I think it's unmanaged as you mentioned you imported same environment.

    You could check following to find the root cause-

    - Import old solution again  if you have any backup which imported earlier to make sure there is no environment related issue.

    -compare old solotion XML with new exported solutions

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,914 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,549 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans