Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics NAV forum
Answered

ADCS error in Nav 2015

Posted on by Microsoft Employee

I have not encountered this error before, and can't find anything on it.  We have a Nav 2015 client with separate servers for database, app server, and web (help, web client).  I am trying to setup ADCS, with the VT100Plugin service installed on the web server, and config pointing to the app server.  From another machine, on a telnet client, when I hit the VT100Plugin, I get the following error in the telnet client: 'Requeue of message failed after sequential message processor errors.'

In the event log on the VT100Plugin server, I get the following error:

Internal Error in Navision VT100Plugin

------------------------------------------------------------------------------------

Object : Messagerprocessor

Error No : FFFFFFFF

Description : Error in the communication: The HTTP request is unauthorized with client authentication scheme 'Negotiate'. The authentication header received from the server was 'Negotiate oXEwb6ADCgEBomgEZmBkBgkqhkiG9xIBAgIDAH5VMFOgAwIBBaEDAgEepBEYDzIwMTUwNDMwMTIxMzQzWqUFAgMEqcOmAwIBKakPGw1GT0NMSU5LLkxPQ0FMqhcwFaADAgEBoQ4wDBsKdHNEeW5hbWljcw=='.

I can pull up the ADCS web service from a browser.  The user running the service has been added as a SUPER user in Nav.

Any idea what I am missing here?

Thanks in advance for any help -- I may have just stared at this too long and am just overlooking something...

  • Verified answer
    Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: ADCS error in Nav 2015

    I have finally got this working, and wanted to follow up here.  The issue has something to do with the client's network, DNS, SPN, or delegation.  I can get the service to run properly if I setup the VT100Plugin to use the App Server's IP Address, rather than the computer name and domain.  I had tried this earlier, but with a different user that already had delegation and SPN records setup.  

    I do not have Admin rights on their network or machines, so I can not dig much further into it, but for now, at least I have it working by using the IP Address to the NAV Server.

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: ADCS error in Nav 2015

    I walked back through the steps from the link (thanks Sandeep!), and verified each, but still get the same error.  I have also compared to other clients, running NAV2013R2 and older versions and using ADCS, but can not find anything that stands out.  We have other web services published in this same environment, and they work without any issue.  It seems to be an issue with the VT100Plugin?  

    Anyone have any other thoughts?  I appreciate the link, Sandeep.  Very good step-by-step directions included, and will definitely be helpful for others trying to get ADCS setup.

  • Suggested answer
    Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: ADCS error in Nav 2015

    have you configured everything according to this page:

    www.navisioncanbefun.com/.../adcs-automated-data-capture-system

    if not please check it once..

  • Suggested answer
    Suresh Kulla Profile Picture
    Suresh Kulla 43,638 on at
    RE: ADCS error in Nav 2015

    Yes, if you are using Navision web service IIS is not applicable.  I have not used ADCS but will throw some ideas for debugging

    The VT100Plugin service, do you know which account it is using, i believe that is the user credentials being send to webservice and may be worth checking if that user is authorized user in Navision

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: ADCS error in Nav 2015

    Since the web service is being offered up through the Nav Server, on the soap client port, IIS shouldn't be applicable here, correct?  I did check to verify IIS had Windows authentication enabled, but this would only be for a default site on port 80.

  • Suggested answer
    Suresh Kulla Profile Picture
    Suresh Kulla 43,638 on at
    RE: ADCS error in Nav 2015

    Check the webserver authenticaiton in IIS and try enabling windows authentication.

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,696 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,490 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans