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Session Id : am/FDOnZbjZTvBsuh+mmHj
Microsoft Dynamics SL (Archived)

ROI.exe has stopped working

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Posted on 11 Jul 2019 15:26:06 by 101

Hi, good morning, recently we had a problem with ROI and the message: "ROI.exe has stopped working", the problem was presented in the main server and to all clients, the help in the internet suggested setting a default printer and thus could continue printing reports, this solution did not help me because all clients had a default printer and the error message indicated an overflow

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After reviewing the RptRuntime tables, we noticed that the print jobs were not being erased from there, and the RI_ID was increasing more and more

The RI_ID field is of type smallint and the maximum value is 32767 In my case the value of RI_ID had increased so much that it did not allow me to print anything
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Solution:
Delete records from the RptRuntime table of the DYNSYS and DYNAPP database, so that RI_ID takes a new value When deleting the records and generating new reports and print jobs, the RI_ID will go hand in hand in both tables
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I hope this helps you solve the problem with "ROI.exe has stopped working"

regards

*This post is locked for comments

  • CFROTON Profile Picture
    4,710 on 11 Oct 2019 at 16:58:31
    RE: ROI.exe has stopped working

    ROI.EXE has stopped working error message in Microsoft Dynamics SL

    Applies to: Dynamics SL 2011Microsoft Dynamics SL 2011 Service Pack 1

    Symptoms

    When you try to print any report in Microsoft Dynamics SL 2011, you receive the following error:

    ROI.EXE has stopped working

    Cause

    The RI_ID value in the RPTRUNTIME table has exceeded the limit of 32,767.

    Resolution

    Clear the records in the RPTRUNTIME table to reset the RI_ID value back to 1.  To do this, follow these steps:

    Verify that all users have logged out of Microsoft Dynamics SL

    Start Microsoft SQL Server Management Studio

    Run the following statement against the SL System database and the SL Application database(s)

    delete from rptruntime

    More Information

    The RPTRUNTIME table contains temporary information that relates to an active print process. Typically this table is empty when there are no users running a report. Ocassionally a record may be stranded in this table which can increase the chances of maxing out the RI_ID values.

  • Mark E Profile Picture
    6,445 on 11 Jul 2019 at 15:45:07
    RE: ROI.exe has stopped working

    Just ran into this at another site recetly, there is a KB article on this:

    [View:https://support.microsoft.com/en-us/help/2721084/roi-exe-has-stopped-working-error-message-in-microsoft-dynamics-sl:750:50]

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