Skip to main content

Notifications

Announcements

No record found.

Customer Service forum
Answered

Agent script not loading - Customer Service Workspace App

Posted on by 15

Hi guys

Recently started using the Customer Service Workspace App and just experiencing an issue with the Agent Script functionality.

I have created a basic Agent script with just basic text steps along with associating the agent script to a Session template.

However when I load up the Workspace app, and go to Agent Scripts, I receive the following error
"Agents scripts haven’t been created or couldn’t load. Please contact your administrator."

Can anyone help point out where I have gone wrong ? 

With regards to the session template, I have associated it with the Lead entity.

Thanks

Nick

Categories:
  • Nickvdh Profile Picture
    Nickvdh 15 on at
    RE: Agent script not loading - Customer Service Workspace App

    Hi Leah

    Thank You So Very Much.

    Managed to come right using the above steps.

    Will look at creating a different profile and link it to the Lead entity, but hopefully should be okay with the steps you showed me now.

    Thank you once again !!

  • Verified answer
    Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Agent script not loading - Customer Service Workspace App

    Hi Nickvdh,

    No, Channel is not required.

    For example, I also meet the same error with you, it appears the same information, but you can load agent script as following two steps.

    pastedimage1614756014458v4.png

     1.Assign app profiles to users.

    Overview of app profile manager | Microsoft Docs

    (1) Go Power App and navigate to ‘Apps’ tab to find ‘Customer service workspace’ app.

     https://go.microsoft.com/fwlink/p/?linkid=2142083 

    (2) Click … to beside the Customer Service workspace app, and then select App profile manager on the menu that appears.

    pastedimage1614755448511v1.png

    (3) Open ‘Customer Service workspace - default profile’ to assign user you need.

    pastedimage1614756423331v1.png

    (4)Test

    pastedimage1614756045300v5.png

    2.Add agent script to the correct session template.

    From previous step, Customer Service workspace - default profile has default session template---'Case entity session - default template'.

    pastedimage1614756137032v6.png

    so you need add agent script to it.

    pastedimage1614756259687v7.png

    Test.

    pastedimage1614756367176v8.png

    Regards,

    Leah Ju

    Please mark as verified if the answer is helpful. Welcome to join hot discussions in Dynamics 365 Forums.

  • Nickvdh Profile Picture
    Nickvdh 15 on at
    RE: Agent script not loading - Customer Service Workspace App

    Hi Leah

    Thanks very much for the informed response.

    Just to confirm, you will Have to setup some kind of channel (chat/phone) for example , to link up with the work streams and then the session templates and then finally the Agent script.

    It isn't possible just to have the agent script just show up without that channel set up ?

    Thanks

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Agent script not loading - Customer Service Workspace App

    Hi Nickvdh,

    Each workstream links to a template that defines how sessions for the workstream will operate. So you will have at least one session template defined for each channel.

    So you need ensure that session template you created is added to the workstream you are using.

    pastedimage1614675832823v1.png

    workstream with seeeion template.

    pastedimage1614675885768v3.png

    session template with agent scrip

    pastedimage1614675912150v4.png

    Then in the customer service workspace app.

    pastedimage1614676044009v5.png

    Regards,

    Leah Ju

    Please mark as verified if the answer is helpful. Welcome to join hot discussions in Dynamics 365 Forums.

  • Nickvdh Profile Picture
    Nickvdh 15 on at
    RE: Agent script not loading - Customer Service Workspace App

    Hi Leah

    Please see images below. 
    First one is the error I receive when opening up a Lead record in the Customer Workspace App.

    pastedimage1614663616057v1.png

    Below image is the agent script with just a basic text step

    pastedimage1614664024609v2.png

    below images are the session template related to the Lead entity, along with adding the related agent script.

    pastedimage1614664084545v3.png

    pastedimage1614664106160v4.png

    Any idea on where I am going wrong ?

    Thanks

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Agent script not loading - Customer Service Workspace App

    Hi Nickvdh,

    Ca you provide screenshot about error and agent script?

    Regards,

    Leah Ju

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,835 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,526 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans