Skip to main content

Notifications

Announcements

No record found.

Business Central forum
Unanswered

Can't install AL extension version 13.1

Posted on by 2
Hi all,
 
Recently my cloud BC environment has been updated to runtime version 13.1.
 
I've been trying to update my development environment (VSCode) to the latest version but to no avail. When I try to install other versions of the AL Language extension, the latest release version available to me is 12.7.964847. When I switch to the pre-release version, the latest version available is 13.0.921843.
 
After installing the above version (13.0.921843) and trying to update symbols, this is what I get:
 
[2024-07-11 15:42:35.40] This AL extension version for Visual Studio Code cannot be used with the specified server.
Please update the AL extension from the Visual Studio Code marketplace.
 
Additional information:
Server details
- Runtime: 13.1
- Web API: 6.0
- Debugger: 6.0
 
AL extension details
- Supported runtimes: 1.0, 2.0, 2.1, 2.2, 2.3, 2.4, 3.0, 3.1, 3.2, 4.0, 4.1, 4.2, 4.3, 4.4, 4.5, 5.0, 5.1, 5.2, 5.3, 5.4,
5.5, 6.0, 6.1, 6.2, 6.3, 6.4, 6.5, 6.6, 7.0, 7.1, 7.2, 8.0, 8.1, 9.0, 9.1, 9.2, 10.0, 10.1, 10.2, 11.0, 11.1, 12.0, 12.1, 13.0
- Supported Web API: 1.0, 2.0, 3.0, 4.0, 5.0, 6.0
- Supported debuggers: 1.0, 2.0, 3.0, 4.0, 5.0, 6.0
 
The end result is that I just can't build my BC extension anymore due to the lack of updated symbols.
 
So, my question is, why can't I download the new version and how can I fix that?
 
Thanks in advance for any help.
 
Categories:
  • Can't install AL extension version 13.1
    hi
     
    I had the same issue today. You should update Visual Studio Code. After that you will be able to install new versions of AL Extension

    PS. oops, missed your last comment. You did update VSCode already )
  • AM-11070336-0 Profile Picture
    AM-11070336-0 2 on at
    Can't install AL extension version 13.1
    I tried it on a second machine and was able to download latest 13.1 version. Then I compared the dev environment and it happens that VSCode on the machine where the download was failing was not updated to the latest available version. 
     
    After manually installing a new VSCode version on top of it, it started downloading the symbols correctly.
     
    So, if you ever find this issue, remember to check your VSCode version. In doubt, install the latest VSCode available.
     
    It's a shame that there is no mention to any specific VSCode version in AL Externsion release notes. There is simply no way to know what VSCode version is required. 
     
    Thank you all for your feedback.
     
    Cheers,
  • YUN ZHU Profile Picture
    YUN ZHU 64,374 Super User on at
    Can't install AL extension version 13.1
    Hi, I tried it and didn't encounter your problem.
     
    Thanks.
    ZHU
  • AM-11070336-0 Profile Picture
    AM-11070336-0 2 on at
    Can't install AL extension version 13.1
    Hi,
     
    As I mentioned, the latest version that appears to me is 12.7.964847 (using the release branch) 
     
     
    and 13.0.921843 using the pre-release branch
     
     
     
     
     
  • gdrenteria Profile Picture
    gdrenteria 5,168 Super User on at
    Can't install AL extension version 13.1
    Hi
    When you access this option, the latest version does not appear?
     
    BR
    GR

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 288,459 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,783 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans