Announcements
No record found.
I have installed management reporter and when I add/modify a user I get the the following error
“The operation could not be completed due to a failure on the server.”
Is this related to sql server?
*This post is locked for comments
Hi George,
Typically this is caused by one of the following:
1. The user you are trying to add does not have the name filled out in Active Directory. For example if you are adding user domain\IT_Support the user may not have one of the fields filled out here related to name. These fields are required for MR as we key off of them.
2. If there are any restrictions in Active Directory to prevent viewing of the Users container this could prevent us from reading the name of users as described above.
3. Sometimes there are restrictions for specific users. Check to see if you are aware of any permission restrictions to the user running the Management Reporter Application Service user, or the user running SQL Server.
Often there is a better error for Management Reporter in Windows Event Viewer. It may either be on your workstation where MR is, or on the Server itself. The Source should be listed as Management Reporter Designer or something Management Reporter depending where it ocurred. It will be logged in the Application Event Log. See if you can get a better error here and I can give a better suggestion of where to look.
Thanks
Where do you locate the active directory? Is that on sql server?
I checked the event viewer and got some long complex error saying
Microsoft.dynamics.performance.reporting.security client.security proxy
George,
if you receive this error when adding any user I would suggest uninstalling/reinstalling MR from a domain user with local admin credentials. The user running some of the services may not have rights to read Active Directory.
Active Directory is on a Domain Controller, or on a PC with Active Directory tools. Active Directory Users and Computers under the Administrative Tools control panel. If you are not sure where this is then you need to work with someone in IT who administers Active Directory as this can be complex depending on any custom permissions that have been setup.
I will respond to your other thread in a minute.
I can add a new user and grant the user access to the company, but then I get the error after the user has been created. The intial user has administrative rights and is a top level domain user. I will check with IT and see if the user can read the active directory
Under review
Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.
Congratulations to our community stars!
Expanding mentorship, skilling, and AI innovation
These are the community rock stars!
Stay up to date on forum activity by subscribing.