web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

No record found.

News and Announcements icon
Community site session details

Community site session details

Session Id :
Microsoft Dynamics GP (Archived)

Econnect Error when Submitting transaction with Panatracker

(0) ShareShare
ReportReport
Posted on by 165

We have eOne Smartconnect installed and also Panatracker.  I create a PO in GP and then through the Handheld I receive in the PO.  Everything looks good.  Then when I SUBMIT from the handheld i get the following error message.  I spent a couple of hours with Tectura yesterday and we have yet to figure out why we are getting the 'item with the same key has already been added' error.  Everything appears to be setup correctly but we are definately missing something.  Does anyone have any ideas or has anyone seen this error message before?

 

Thanks,

 

Craig

 

The message from the host is:

An error occurred while submitting transaction ID d691ec4e-9f4c-4d95-b5c9-c59bb128330f.

An error occurred performing the Receiving transaction.

eConnect rejected this transaction.

An item with the same key has already been added.

 

_____________________________________________________________________________________

 

_____________________________________________________________________________________

The message sent to the host was:

<?xml version="1.0" encoding="utf-16"?>

<eConnect xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

  <POPReceivingsType>

    <eConnectProcessInfo xsi:nil="true" />

    <taRequesterTrxDisabler_Items xsi:nil="true" />

    <taUpdateCreateItemRcd xsi:nil="true" />

    <taUpdateCreateVendorRcd xsi:nil="true" />

    <taCreateVendorAddress_Items xsi:nil="true" />

    <taPopRcptLotInsert_Items />

    <taPopRcptSerialInsert_Items />

    <taPopRcptLineInsert_Items>

      <taPopRcptLineInsert>

        <POPTYPE>1</POPTYPE>

        <POPRCTNM>RCV000004</POPRCTNM>

        <PONUMBER>PO-009698</PONUMBER>

        <ITEMNMBR>ABRASBELT64850</ITEMNMBR>

        <ITEMDESC>6" X 48" Norton 50 Grit 27696 Sand Belts</ITEMDESC>

        <VENDORID>1STAL02</VENDORID>

        <RCPTLNNM>16384</RCPTLNNM>

        <VNDITNUM>ABRASBELT64850</VNDITNUM>

        <UOFM>Ea</UOFM>

        <QTYSHPPD>10</QTYSHPPD>

        <AUTOCOST>1</AUTOCOST>

        <LOCNCODE>10ARTESIA</LOCNCODE>

        <POLNENUM>16384</POLNENUM>

        <receiptdate>5/20/2013</receiptdate>

        <AutoAssignBin>0</AutoAssignBin>

      </taPopRcptLineInsert>

    </taPopRcptLineInsert_Items>

    <taPopRcptMultiBin_Items />

    <taPopRcptLineTaxInsert_Items xsi:nil="true" />

    <taPopRctUserDefined xsi:nil="true" />

    <taPopDistribution_Items xsi:nil="true" />

    <taAnalyticsDistribution_Items xsi:nil="true" />

    <taPopRcptHdrInsert>

      <POPRCTNM>RCV000004</POPRCTNM>

      <POPTYPE>1</POPTYPE>

      <VNDDOCNM>555896</VNDDOCNM>

      <receiptdate>5/20/2013</receiptdate>

      <BACHNUMB>PTGP_RECEIVE</BACHNUMB>

      <VENDORID>1STAL02</VENDORID>

      <AUTOCOST>1</AUTOCOST>

      <USRDEFND5>[Device]BOSScanner5[/Device][TrxReceiving.Oid]d691ec4e-9f4c-4d95-b5c9-c59bb128330f[/TrxReceiving.Oid]</USRDEFND5>

    </taPopRcptHdrInsert>

    <taMdaUpdate_Items xsi:nil="true" />

  </POPReceivingsType>

</eConnect>

_____________________________________________________________________________________

 

_____________________________________________________________________________________

Additional diagnostic information:

                Panatracker.Model Version: 6.1.12.3

                Host Adapter: DynamicsGP v11

               

             

              

               

           

                Database host: artmecgpsql

                Database name: PanatrackerGP

 

               

 

*This post is locked for comments

  • Suggested answer
    nzajork Profile Picture
    5 on at

    Hi Craig,

    I know we already addressed this back in May, but I wanted to share this with anyone who was also having this issue.  Basically, the error message given is not clear as to what the problem is.  It turned out that functional currency was not set up and it is required to be set up for eConnect to function properly.

    For more information, you can go to: support.panatrack.com/.../23857911-eConnect-Error-An-item-with-the-same-key-has-already-been-added-

    Thank you,

    Nicole Zajork

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Women in Power Builds Momentum

Expanding mentorship, skilling, and AI innovation

Congratulations to the August Top 10 Community Leaders

These are the community rock stars!

Leaderboard > 🔒一 Microsoft Dynamics GP (Archived)

Last 30 days Overall leaderboard

Featured topics

Product updates

Dynamics 365 release plans