Hi Shanenon,
Please take a look through the below and see if this resolves the issue:
Error message in the QBPost.log event log when you post to Intuit QuickBooks: "Transaction split lines to Accounts Receivable must include a customer on that split line"
Article ID: 837803
First Published: 2/27/2004
Last Revised: 7/8/2011
SYMPTOMS
When you post a closed batch to Intuit QuickBooks 2003, QuickBooks 2004, QuickBooks 2005, QuickBooks 2006, QuickBooks 2007, or QuickBooks 2008, the following event is logged in the QBPost.log event log:
Transaction split lines to Accounts Receivable must include a customer on that split line.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
CAUSE
This problem occurs because the standard Accounts Receivable account type in QuickBooks requires more information than Microsoft Dynamics Retail Management System Store Operations provides.
RESOLUTION
To resolve this problem, create a new account that can be used for accounts receivable. To do this, follow these steps:
1. Start QuickBooks.
2. Create a new account by clicking Edit and then clicking New Account .
3. Set the Account Type to Other Current Assets.
4. Fill out the remaining fields on the new account screen.
5. Click OK to save your changes.
6. Start Store Operations Manager.
7. Import your QuickBooks accounts information. To do so, click Utilities , click Import QuickBooks , click to select the Accounts only check box, make sure that all other options are cleared, and then click Import .
8. In Store Operations Manager, click Journal , click Assign GL Accounts , and then modify the Store Account: Paid On and Store Account: Paid To GL accounts to select the new account that you created in steps 1-5.
9. Click Journal , click Post Closed Batches , select the batch or batches, and then click Post . Post the batch that was causing the error to make sure that it posts without error.
_______________________________________________
For anyone who is not already aware, Mainstream support for Microsoft Dynamics RMS 2.0 ended on July 10, 2016; and extended support ends on 7/13/2021:
community.dynamics.com/.../microsoft-dynamics-rms-2-0-mainstream-support-discontinuation-july-10-2016
support.microsoft.com/.../search
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This is less than 8 months from now; and you can continue using RMS after this date but technical support will not be available.
I would recommend checking with your partner in regard to what they may recommend as a replacement system after the extended support end date.