Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics SL forum
Answered

SL 2011 and ROI

Posted on by Microsoft Employee

I have an existing client using SL 2011.  They have several workstations running just fine but we introduced a new workstation (Windows 7 64-bit) and installed the SL 2011 client.  They can connect to SL just fine and work all the screens.  However, when they try to print or print preview and SL report they get ROI has stopped working errors.  I have installed Crystal Reports 2008 SP$ (though it says it is SP# during the install, annoying).  I have made certain that the printer is a valid printer and works with various Office modules.  I even set up a dummy local printer and tried using it with the same error.  I have set up the debug.tlb file and traced through the ROI process and the error occurs in the middle of looking for the RIPARAMS and long before even trying to connect to the printer.  I have uninstalled and re-installed the SL client and Crystal SP4.  There are no entries in the windows event log or in the SQL event log related to what is going on.

Has anyone encountered this before and "got the t-shirt"

 

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: SL 2011 and ROI

    Filly found a solution.  I installed 2011 SP1 and that resolved the problem  Not sure why since the failing workstation had the same version of Windows 7 and the other working workstations but it took care of the problem.  Come to think of it, there was one difference with this workstation.  It had the Dynamics Report Writer client installed on it while the functional workstations did not.  No idea if this contributed to the issue or not.

  • Verified answer
    Butch Adams Profile Picture
    Butch Adams 4,757 on at
    RE: SL 2011 and ROI

    Well I didn't have too much hope in that one, you've been so thorough to this point I am just shooting anything out there I can find in my notes about "Ways to break ROI" :)

    We actually had an issue at a client where the July Windows updates started causing a bunch of ROI errors. This was on a Citrix environment though. When the Citrix boxes were reverted, the problems went away.

    Since it is a new machine, do you by chance have a pre-windows update restore point you can go to and see if you can get it working?

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: SL 2011 and ROI

    Butch, no go on your latest suggestion.  In fact, crpehlpr is not even part of SL 2011.

    Last night I downloaded PROCMON and ran a trace from clicking print preview up to the error.  I then did the same on a functional workstation and, upon filtering to ROI.EXE, I see that the functional workstation makes several ODBC requests towards the end while the failing workstation does not.  Now, what I cannot tell is if the ODBC requests occur beyond where we fail or if the problem is the failing workstation actually communicating with the ODBC.  I did open the ODBC administrator and saw the connection definition and was able to do a test connect so I know that is working outside of SL.  Now I am trying to see if SL is having an issue talking with the ODBC.  My initial thought is that it must be talking because the ROI process creates the ODBC connection in the first place.  Still, it is something to look at.

    As you may know, PROCMON traces are so much fun to look at.  Trying to filter out failure results that are normal so that you can find the true failing result is always a challenge.

  • Butch Adams Profile Picture
    Butch Adams 4,757 on at
    RE: SL 2011 and ROI

    Here's another possibility:

    Set the Data Execution Prevention feature to enable the Crpehlpr.exe file and the Roi.exe file to run. To do this, follow these steps:

    1.Right-click My Computer, and then click Properties.

    2.In Windows Server 2003 or Windows XP, click the Advanced tab. In Windows Vista, Windows 7, or Windows Server 2008, click the Advanced system settings link.

    3.In the Performance section, click Settings.

    4.On the Data Execution Prevention tab, click Add.

    Note The default option is Turn on DEP for all programs and services except those I select.

    5.Browse to the Microsoft Dynamics SL program installation directory or the Microsoft Business Solutions - Solomon program installation directory. If you have an additional drive that is a mapped drive to this installation directory, you must add the file through both paths.

    For example, you install Microsoft Dynamics SL 7.0 to the following folder:

    C:\Program Files\Microsoft Dynamics\SL\Applications

    On the same computer, you map the S drive to the following folder:

    C:\Program Files\Microsoft Dynamics\SL

    When you follow this step, you must add the files by using both of the following paths:◦C:\Program Files\Microsoft Dynamics\SL\Applications\

    ◦S:\Applications\

    6.Locate and then click to select the following file:

    Crpehlpr.exe

    .

    7.Click Open, click Apply, and then click OK.

    8.Repeat step 1 through step 7 for the Roi.exe file

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: SL 2011 and ROI

    Butch, thanks for the reply but that was one of the first steps I did (forgot to mention that) as I have also found this error to be related to not recognizing the printer.  Like you, that has fixed the issue with some of my other clients but normally when they are using a terminal services session.  Like I said in my post, the ROI trace is stopping quite a bit before it even goes after the printer.  It is in the process of looking up RIPRARMS when it aborts.  Unfortunately, without the code to ROI there is no way to tell exactly what it was trying to do around that time.  the RIPARAMS at the items set on the ROI screen for sort and select purposes that lead up to the modifications to the query behind a report and all that work is done before going after the printer.  It is acting like it cannot find a needed DLL or is finding an incompatible DLL.  Hopefully someone has been down this road and finally figured it out.

  • Butch Adams Profile Picture
    Butch Adams 4,757 on at
    RE: SL 2011 and ROI

    You can try going into printer setup and checking the "Use Windows Default Printer" box. I've seen that fix it in the past.

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 288,420 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,672 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans