Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics SL forum
Unanswered

System Message 10206 in custom Service Call Entry screen

Posted on by 10

Hi all,

I'm looking for some help with the error below -

I have a user who is getting this message infrequently in a custom version of the Service Call Entry screen that we have set up. They're also getting the same error on another cursor too.

I've tried recreating the issue but had no luck, searching and saving on that cursor seem to work fine for me. The cursor is called created normally in form load -

Call SqlCursorEx(csr_smServCall, LEVEL0, "csr_smServCall", "smServCall", "smServCall")

and all that it's used for are a PVCheckFetch1 and some SUpdate1 and SInsert1 calls. If anyone has any idea what's wrong, or even some place to start looking, I'd really appreciate it. The error message doesn't really make sense to me, it seems to be saying the cursor doesn't have the rights or isn't matching properly to do the update, but it's working 99% of the time.

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,914 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,549 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans