Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics AX forum
Suggested answer

Workflowstep "Post supplier invoice" not executed although WF is "completed"

Posted on by 115

hi all, 

I have the following situation in our Ax Prod system (Ax2012 R2CU9): we have a very simple workflow (WF) in place to handle all the invoices which were sitting in our invoice pool prior to the implementation and go-live of a full WF solution for handling purchas-invoices in Ax. This was necessary as once we went live with our full WF solution, the invoice which were sitting in our invoice pool and were in the midst of our old process (without WF), require a WF to be posted to a purchase-order. So we created a simple WF which consists of two steps:

  • approval  - auto-approve based on a simple criteria
  • posting of supplier invoice

pastedimage1598455281111v1.png

In general this is working fine to handle the remaining old invoices and get them fully processed but for some invoices (4 cases) the WF completes but the posting of the pending supplier-invoice is not done although the WF is completed which means the posting would be done. I can delete the pending invoice and recreate the pending supplier-invoice and submit it again to the WF but it completes within minutes but the posting does not take place. I tried to manually post the pending supplier-invoice, but i am able to click the "post button" but it does not work.

As i have totally no idea where i should look or what the issue might be, i need your support to clear this. 

Looking forward to your feedback.

kind regards, 

Jo

  • Suggested answer
    RE: Workflowstep "Post supplier invoice" not executed although WF is "completed"

    Hi Jo, 

    Hope you are doing well, Please consider the information shared above is insufficient to proceed with our investigation and identify the RCA. 

    Please try to log a support request for Microsoft Support in order to proceed with our investigation. 

    Thanks in advance. 

    Regards, 

    Momen Mansour

  • Jo.L Profile Picture
    Jo.L 115 on at
    RE: Workflowstep "Post supplier invoice" not executed although WF is "completed"

    hi Ludwig, 

    No special criteria etc... are specified. The workflow which is used is only needed as a migration-WF to get the invoices processed which were pending prior to the go-live of the full WF solution. As this full WF solution required us to activate functions that also affected these "old" invoices to have a WF, we decided to activate the most simple WF possible:

    pastedimage1598526418655v1.png

    For both WF-elements no filter, criteria have been specified. 

    For the majority of the old invoice to which we appy the above WF, everything works fine. We only have limited list of invoices where we have this issue. 


    i have asked our helpdesk to assign a developper so i can walk it through with him and debugging can take place.

    i will keep you updated on the outcome.

    kr, 

    Jo

  • Suggested answer
    Ludwig Reinhard Profile Picture
    Ludwig Reinhard Microsoft Employee on at
    RE: Workflowstep "Post supplier invoice" not executed although WF is "completed"

    Hello Jo,

    Many thanks for the update.

    Do you have any other specific setting / filter/ ... enabled for those four invoices / vendors in your workflow?

    If you cannot find anything, then I would suggest to get a developer involved who could help you debugging the issue.

    Best regards,

    Ludwig

  • Jo.L Profile Picture
    Jo.L 115 on at
    RE: Workflowstep "Post supplier invoice" not executed although WF is "completed"

    hi Ludwig,

    I checked our settings and find out that the parameter is defined as "allow with warning". So no approval is required.

    pastedimage1598515731889v1.png

    When i check the pending invoice itself, the last match status has the value "ok", so we have a successfull match between PO & invoice.

    kr, 

    Jo

  • Suggested answer
    Ludwig Reinhard Profile Picture
    Ludwig Reinhard Microsoft Employee on at
    RE: Workflowstep "Post supplier invoice" not executed although WF is "completed"

    Hello Jo,

    If the process works in general but not for the four invoices then there must be something 'special' with those four invoices.

    I had a quick look at LCS and noticed that there is a fix available (issue no 3238454), which mentions that things might not work correctly if the 'post invoice with discrepancies' parameter is set to 'require approval'.

    Is this the case in your system and do those four invoices show discrepancies?

    If this is the case, try to install the hotfix in your demo/test environment to check whether it resolves the problem.

    If it does, apply it to your live environment.

    Best regards,

    Ludwig

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 288,420 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,672 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans