web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

No record found.

News and Announcements icon
Community site session details

Community site session details

Session Id :
Microsoft Dynamics SL (Archived)

SL 2015 CU1 Application Server for Quick Send errors with SQL Message 916

(0) ShareShare
ReportReport
Posted on by 460

Testing out Application Server to use for Quick Send PO's.

Application Server user gets a SQL Server Message 916 when it is trying to send the email.

The SQL Server Message 91 states that the server principal 'xx\xx' is not able to access the system database under the current security context.

I ran synchronize ownership and it did not help; I changed the SQL user to be a sysadmin and that did not work; I removed the SQL user from the application and system databases and added it back with no change in the error message.

I made sure the SL user had rights to Application Server before creating the Application Server associated with his user.  Does the user need rights to Quick Send screens in order to process?

Could this be related to a network rights issue? I wouldn't think so since it's the SQL Server message specific to the user and system database.

Any assistance would be appreciated. 

Laura Vogel

*This post is locked for comments

  • Community Member Profile Picture
    on at

    Just curious if you ever got this resolved.  If so, what was the resolution?

  • Suggested answer
    CFROTON Profile Picture
    4,710 on at

    Laura -

    Thank you for posting your question to the forum. I would look at the permissions of your Application Server user in SL and possibly the SL permissions of the user submitting the request. To help narrow this down, can you let us know the following:

        - Does this happen on all requests submitted to AS and emailed, or only for a specific user?

        - Has this ever worked, or are you just setting AS up new at this site?

    I agree that this does not seem like a network issue. But I know in the AS log it should show if the report was run successfully, then when the email is called and sent. Leading up to the SQL error do you see anything else that could help point to the issue?

    If the user the error is referencing the AS user, if you add that user to the Administrator group in SL does it work? If you try this, be sure to stop AS, close the SL client this user is logged into. Open SL as the SYSADMIN user and bump up his rights in SL, then have the AS user log back into SL and run AS.

    The only other option would be to run a SQL trace to see exactly at what line the SQL 91 error is being returned against.

    Hope this helps.

    Carolyn

    MSDSL Technical Support

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Women in Power Builds Momentum

Expanding mentorship, skilling, and AI innovation

Congratulations to the August Top 10 Community Leaders

These are the community rock stars!

Leaderboard > 🔒一 Microsoft Dynamics SL (Archived)

Last 30 days Overall leaderboard

Featured topics

Product updates

Dynamics 365 release plans