web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

No record found.

News and Announcements icon
Community site session details

Community site session details

Session Id :
Supply chain | Supply Chain Management, Commerce
Suggested Answer

retail self service error FO VM upgrade

(0) ShareShare
ReportReport
Posted on by 44

I am trying to update the FO VM upgrade and at step no. 52 I got this error 

GlobalUpdate script for service model: RetailSelfService on machine: localhost
Update Retail self service.
UpdateRetailSelfService.ps1 failed. at step 52 

In the logs file I get the message exception:

PSMessageDetails :
Exception : System.Management.Automation.RuntimeException: Following packages could not be uploaded. Please upload them manually. C:\Temp\Uninstall\PU52\RetailSelfService\Packages\StoreSystemSetup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\RealtimeServiceAX63Setup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\ModernPOSSetup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\ModernPOSSetupOffline.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\RetailModernPOS_ARM.appx
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\AsyncServerConnectorServiceSetup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\HardwareStationSetup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\VirtualPeripherals.msi

TargetObject : Following packages could not be uploaded. Please upload them manually. C:\Temp\Uninstall\PU52\RetailSelfService\Packages\StoreSystemSetup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\RealtimeServiceAX63Setup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\ModernPOSSetup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\ModernPOSSetupOffline.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\RetailModernPOS_ARM.appx
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\AsyncServerConnectorServiceSetup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\HardwareStationSetup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\VirtualPeripherals.msi

CategoryInfo : OperationStopped: (Following packa...ipherals.msi
:String) [], RuntimeException
FullyQualifiedErrorId : Following packages could not be uploaded. Please upload them manually. C:\Temp\Uninstall\PU52\RetailSelfService\Packages\StoreSystemSetup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\RealtimeServiceAX63Setup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\ModernPOSSetup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\ModernPOSSetupOffline.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\RetailModernPOS_ARM.appx
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\AsyncServerConnectorServiceSetup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\HardwareStationSetup.exe
C:\Temp\Uninstall\PU52\RetailSelfService\Packages\VirtualPeripherals.msi

ErrorDetails :
InvocationInfo : System.Management.Automation.InvocationInfo
ScriptStackTrace : at <ScriptBlock>, C:\Temp\Uninstall\PU52\RetailSelfService\scripts\Upgrade\UpdateRetailSelfService.ps1: line 291
at <ScriptBlock>, <No file>: line 3
at <ScriptBlock>, <No file>: line 1
PipelineIterationInfo : {}

How do I manually upload that packages listed in that message.

  • Suggested answer
    Shafeeque P. Profile Picture
    6,533 Moderator on at

    Could you please check if the "Azure Storage Emulator" service is started as per the below article ?

    www.gangsta.se/.../error-on-step-retail-self-service-on-d365fo-update

  • Ammad majid Profile Picture
    44 on at

    Hi Shafeeque, I have gone through the document and run the command and azure storage emulator is already running and throws this error:

    Windows Azure Storage Emulator 5.10.0.0 command line tool
    Error: The storage emulator is already running. Only one instance of the application can be run at the same time.

    and I run the step again it is throwing the error still at step 52 

    Update Retail self service.
    UpdateRetailSelfService.ps1 failed.

  • Shafeeque P. Profile Picture
    6,533 Moderator on at

    Restarting the VM manually and then resuming the deployment has some times resolved issues for me. If you don't intend to download the self service installers from the environment your are currently working on, there is no harm in marking this step as manually completed. I am not sure, which method are you currently using to upgrade. If you are using command line upgrade, you can mark the step as completed as below.

    https://learn.microsoft.com/en-us/dynamics365/fin-ops-core/dev-itpro/deployment/install-deployable-package 

    pastedimage1668070970756v1.png

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Women in Power Builds Momentum

Expanding mentorship, skilling, and AI innovation

Congratulations to the July Top 10 Community Leaders

These are the community rock stars!

Leaderboard > Supply chain | Supply Chain Management, Commerce

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 99 Super User 2026 Season 2

#2
Paolo Cecchelli Profile Picture

Paolo Cecchelli 73 Super User 2026 Season 2

#3
Aayush Tiwari Profile Picture

Aayush Tiwari 71

Last 30 days Overall leaderboard

Product updates

Dynamics 365 release plans