Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics SL forum
Suggested answer

Received a roi error about Component "SAF.ocx"

Posted on by 30

Today I received a "roi" error in my process manager engine that said:

Component 'SAF.ocx' or of of its dependencies not correctly registered: a file is missing or invalid.

This error occurred on Microsoft Dynamics SL 6.5. What does this error mean? How can this error be fixed?

  • Suggested answer
    Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Received a roi error about Component "SAF.ocx"

    Most likely you tried to install the SL client under a user id that does not have sufficient rights to make registry modifications.  I would suggest that you uninstall the SL client on that workstation and then re-install it right clicking on the setup.exe file and selecting run as administrator.

    The other possibility is that you uninstalled another program and it asked you if you wanted to remove certain files (DLLs and OCX files) no longer used and you responded with yes to that request.  Again, I would start with an uninstall of the client and then a re-install.

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 288,420 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,672 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans