Reports in Management reporter,
Generating them takes alot of time,when you go to report status queue,you find them queued .Anybody has come across the same issues? Any solutions?
Regards,
Charles
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SYMPTOMS
You click the Generate button in Management Reporter for Dynamics ERP but the Report Queue Status window lists the Status as Queued rather than Processing.
CAUSE
There are five potential causes for this error:
Cause 1
If the Management Reporter Process Service is on the same machine as the machine hosting your ManagementReporter SQL database. The Process Service may have errored out by attempting to start before SQL Server was accepting connections. See Resolution 1 in the Resolution section.
Cause 2
A SQL Server connection error has occurred and the Management Reporter Process Service needs to be restarted. See Resolution 2 in the Resolution section.
Cause 3
The user running the Management Reporter Process Service does not have sufficient permissions to read from the ManagementReporter SQL Server database. See Resolution 3 in the Resolution section.
Cause 4
The SQL Service Broker on the ManagementReporter SQL Server database is not enabled. See Resolution 4 in the Resolution section.
Cause 5
This can happen if the owner of the Management Reporter database is a Windows User while the SQL Server Service is being run by a local user. If you check the Event Viewer, you may see this message:
An exception occurred while enqueueing a message in the target queue. Error 15404, State 19. Could not obtain information about Windows NT group/user 'domain\user', error code 0x5.
See Resolution 5 in the Resolution section.
RESOLUTION
Resolution 1
If using Windows Server 2008 you can set the Management Reporter Process Service to Automatic (Delayed Start) rather than Automatic.
OR
Restart Process Service manually or with a script similar to the following:
NET STOP MRProcessService
NET START MRProcessService
Resolution 2
Restart Process Service manually or with a script similar to the following:
NET STOP MRProcessService
NET START MRProcessService
Resolution 3
Grant the user running this service the GeneralUser role under the Management Reporter database in SQL Server. This user can be found on the Log On tab under the Services Control panel.
Resolution 4
Run the following statement on the SQL server where your ManagementReporter database resides:
SELECT name, is_broker_enabled FROM sys.databases WHERE name = DB_NAME() AND is_broker_enabled = 1
This statement should return a row for the ManagementReporter SQL Server database. If it does not, run the statement below to re-enable the SQL Service Broker on the ManagementReporter SQL Server database:
ALTER DATABASE [ManagementReporter] SET ENABLE_BROKER WITH ROLLBACK IMMEDIATE;
Resolution 5
Change the database owner to sa or change the SQL Server Service user to a domain user.
Ryan,
Apparantely i restarted the MR process services but the problem is still persisten. I can't access the knowledge base ID yet i have a partnersource ID.
More clarifications and suggestions would appreciated.
Charles
Charles,
I think you had asked this question in another thread as well. If the reports are stuck in queued then there is something preventing the Process Service from generating the reports. It can be one of the following issues:
1. On the Server open the Services control panel and stop and restart the Management Reporter Process Service.
2. The user you installed the Process Service with did not get granted adequate access to SQL Server to read the reports to be generated.
KB 2298248 discusses these issues.
Thanks much,
Ryan
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