Skip to main content
Dynamics 365 general forum
Suggested answer

Dynamics workflow not setting checkbox attribute

editSubscribe (0) ShareShare
ReportReport
Posted on by 1,575

Hello, 

I have a workflow which sets 2 custom contact entity values - a date field and a yes/no field.

The date field gets set consistently but sometimes the checkbox field is not getting changed.

The workflow shows as succeeded even though only one of the two fields has actually been set correctly. 

We have a similar workflow which works consistently but it is setting an option set yes/no/unspecified instead of a checkbox. 

So, my question is, - is there any issue with workflows setting a checkbox to "ticked"?

Thanks for any help. 

- Seamus

Attachments
  • Suggested answer
    Charles Abi Khirs Profile Picture
    Charles Abi Khirs 3,569 on at
    RE: Dynamics workflow not setting checkbox attribute

    Hello,

    In addition to what Wajah suggested, you can enable the Audit history on the System / Entity / Field you are checking this issue in order to verify if the field is being properly set by the workflow or if there is another process who is overriding the value set by the workflow.

  • Suggested answer
    Wahaj Rashid Profile Picture
    Wahaj Rashid 11,317 on at
    RE: Dynamics workflow not setting checkbox attribute

    Hi,

    This looks okay, can you please verify if there re other workflows setting this checkbox?

    Or try converting this workflow to real-time (temporarily) and see if it works every time.

    It is possible this checkbox is being reset by any other process/plugin.

  • Seamus Profile Picture
    Seamus 1,575 on at
    RE: Dynamics workflow not setting checkbox attribute

    workflow_5F00_tick.png

    Hello, the logic of the workflow is fine - the opt-in-date will ALWAYS get populated but occasionally the check-box field above it ("Parent Subscribed") will remain unticked even though the workflow has succeeeded (as evidenced by the opt-in date being set correctly).  Thanks

  • Wahaj Rashid Profile Picture
    Wahaj Rashid 11,317 on at
    RE: Dynamics workflow not setting checkbox attribute

    Hi,

    Thank you for your query.

    There are no known issues with workflows setting a value of two-options field.

    Can you please share logic of your workflow (if possible)?

    Screenshots will help to understand this better.

Helpful resources

Quick Links

New Blog Features Released!

Check out the new community blog features for viewers and authors…

Setting Up Knowledge Sources for Copilot…

Look at how configuring a comprehensive knowledge base is crucial…

Demystifying Copilot with Georg Glantschnig…

Industry experts answer burning questions directly from our amazing Community…

Leaderboard

#1
Andre Arnaud de Calavon Profile Picture

Andre Arnaud de Cal... 283,080 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 222,601 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,138

Featured topics

Product updates

Dynamics 365 release plans