web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

No record found.

News and Announcements icon
Community site session details

Community site session details

Session Id :
Service | Customer Service, Contact Center, Fie...
Unanswered

SLA KPI Error for Case in D365 customer service

(0) ShareShare
ReportReport
Posted on by 5

Hi People,

I have been facing following error whilst trying to save the case after changing Priority .

Exception occured in SLAInstance management custom action : System.ServiceModel.FaultException`1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: Unrecognized request parameter: firstInputDate (Fault Detail is equal to Exception details: ErrorCode: 0x80040315 Message: Unrecognized request parameter: firstInputDate TimeStamp: 2022-10-06T18:09:01.4686652Z -- Exception details: ErrorCode: 0x80040216 Message: System.NotSupportedException: Unrecognized request parameter: firstInputDate: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #9B32B6E1 TimeStamp: 2022-10-06T18:09:01.4686652Z -- ).

Complete Log:

Exception Message: Exception occured in SLAInstance management custom action : System.ServiceModel.FaultException`1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: Unrecognized request parameter: firstInputDate (Fault Detail is equal to Exception details:
ErrorCode: 0x80040315
Message: Unrecognized request parameter: firstInputDate
TimeStamp: 2022-10-06T18:09:01.4686652Z
--
Exception details:
ErrorCode: 0x80040216
Message: System.NotSupportedException: Unrecognized request parameter: firstInputDate: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #9B32B6E1
TimeStamp: 2022-10-06T18:09:01.4686652Z
--
).

ErrorCode: -2147220891
HexErrorCode: 0x80040265

ErrorDetails:
    OperationStatus: 0
    SubErrorCode: -2146233088
    Plugin:
        PluginTrace: [Microsoft.Dynamics.SLAManagement.Plugins: Microsoft.Dynamics.SLAManagement.Plugins.ManageSLAInstancesonTargetEntityCUD]
[494f72d3-fbfa-e911-a81e-000d3a6ed79d: Microsoft.Dynamics.SLAManagement.Plugins.ManageSLAInstancesonTargetEntityCUD: Manages the sla kpi instances for the target entity]
Starting sync workflow 'ManageSLAInstances', Id: 39392897-4f34-ed11-9db0-000d3a580354
Sync workflow 'ManageSLAInstances' completed successfully
Entered Microsoft.Dynamics.SLAManagement.Plugins.ManageSLAInstancesonTargetEntityCUD.Execute(), Correlation Id: 68e7523d-aea9-427d-9103-ad837f2b3f3a, Initiating User: 27c03c84-b836-ed11-9daf-000d3a52d266
Exiting Microsoft.Dynamics.SLAManagement.Plugins.ManageSLAInstancesonTargetEntityCUD.Execute(), Correlation Id: 68e7523d-aea9-427d-9103-ad837f2b3f3a, Initiating User: 27c03c84-b836-ed11-9daf-000d3a52d266

TraceText:
    [Microsoft.Dynamics.Service.Plugins: Microsoft.Dynamics.Service.Plugins.PostOperationIncidentUpdateEntitlement]
    [a468c44e-c204-e711-80ca-02155dc812c3: Post-operation update entitlement for incident]
    Entered Microsoft.Dynamics.Service.Plugins.PreOperationIncidentUpdate.Execute(), Correlation Id: 68e7523d-aea9-427d-9103-ad837f2b3f3a, Initiating User: 27c03c84-b836-ed11-9daf-000d3a52d266
    Exiting Microsoft.Dynamics.Service.Plugins.PreOperationIncidentUpdate.Execute(), Correlation Id: 68e7523d-aea9-427d-9103-ad837f2b3f3a, Initiating User: 27c03c84-b836-ed11-9daf-000d3a52d266
    Entered Microsoft.Dynamics.Service.Plugins.PreOperationIncidentUpdateEntitlement.Execute(), Correlation Id: 68e7523d-aea9-427d-9103-ad837f2b3f3a, Initiating User: 27c03c84-b836-ed11-9daf-000d3a52d266
    Exiting Microsoft.Dynamics.Service.Plugins.PreOperationIncidentUpdateEntitlement.Execute(), Correlation Id: 68e7523d-aea9-427d-9103-ad837f2b3f3a, Initiating User: 27c03c84-b836-ed11-9daf-000d3a52d266
    Entered Microsoft.Dynamics.Service.Plugins.PostOperationIncidentUpdateEntitlement.Execute(), Correlation Id: 68e7523d-aea9-427d-9103-ad837f2b3f3a, Initiating User: 27c03c84-b836-ed11-9daf-000d3a52d266
    Exception: System.ServiceModel.FaultException`1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: Exception occured in SLAInstance management custom action : System.ServiceModel.FaultException`1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: Unrecognized request parameter: firstInputDate (Fault Detail is equal to Exception details:
    ErrorCode: 0x80040315
    Message: Unrecognized request parameter: firstInputDate
    TimeStamp: 2022-10-06T18:09:01.4686652Z
    --
    Exception details:
    ErrorCode: 0x80040216
    Message: System.NotSupportedException: Unrecognized request parameter: firstInputDate: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #9B32B6E1
    TimeStamp: 2022-10-06T18:09:01.4686652Z
    --
    ). (Fault Detail is equal to Exception details:
    ErrorCode: 0x80040265
    Message: Exception occured in SLAInstance management custom action : System.ServiceModel.FaultException`1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: Unrecognized request parameter: firstInputDate (Fault Detail is equal to Exception details:
    ErrorCode: 0x80040315
    Message: Unrecognized request parameter: firstInputDate
    TimeStamp: 2022-10-06T18:09:01.4686652Z
    --
    Exception details:
    ErrorCode: 0x80040216
    Message: System.NotSupportedException: Unrecognized request parameter: firstInputDate: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #9B32B6E1
    TimeStamp: 2022-10-06T18:09:01.4686652Z
    --
    ).
    TimeStamp: 2022-10-06T18:09:01.5467899Z
    --
    Exception details:
    ErrorCode: 0x80040265
    Message: Exception occured in SLAInstance management custom action : System.ServiceModel.FaultException`1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: Unrecognized request parameter: firstInputDate (Fault Detail is equal to Except...)., Correlation Id: 68e7523d-aea9-427d-9103-ad837f2b3f3a, Initiating User: 27c03c84-b836-ed11-9daf-000d3a52d266
    Exiting Microsoft.Dynamics.Service.Plugins.PostOperationIncidentUpdateEntitlement.Execute(), Correlation Id: 68e7523d-aea9-427d-9103-ad837f2b3f3a, Initiating User: 27c03c84-b836-ed11-9daf-000d3a52d266
    
        PII Removed. Length: 851

Activity Id: f36bb6ff-7742-42fd-80ac-0e00004b41a8

pastedimage1665080475852v1.png

Could someone please help ?

  • ChadAlt Profile Picture
    367 User Group Leader on at

    What was the trigger for this message? Were you trying to apply an SLA? If so, has the SLA successfully been applied to other records? I wonder if there could be bad logic in the SLA Items. 

  • Shenoy Profile Picture
    5 on at

    I'm trying to apply SLA to cases. No, when SLA is enabled cases can't be resolved/closed/cancelled.

    I think you are right, bad logic in SLA item could be the cause.

    Please let me know what more do you need from me in this regard to help further ?

  • ChadAlt Profile Picture
    367 User Group Leader on at

    I'd provide screenshots of the SLA Items as well as the KPIs being used for these. That should help. 

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Women in Power Builds Momentum

Expanding mentorship, skilling, and AI innovation

Congratulations to the August Top 10 Community Leaders

These are the community rock stars!

Leaderboard > Service | Customer Service, Contact Center, Field Service, Guides

#1
Travis South Profile Picture

Travis South 54

#2
11manish Profile Picture

11manish 37 Super User 2026 Season 2

#3
ParthPatel249 Profile Picture

ParthPatel249 33

Last 30 days Overall leaderboard

Featured topics

Product updates

Dynamics 365 release plans