Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics SL forum
Answered

Dynamics SL 2015 CU1

Posted on by 235

Just applied CU1 to our Dynamics SL Installation Server + 5 Workstations

Server install went fine as well as 1 workstation

On other 4 Workstations setup ran without error, however, Dynamics looks like this

and the following errors are recorded in the event log

Event id 1000

Faulting application name: MSDynamicsSL.exe, version: 9.1.30423.1, time stamp: 0x55390340

Faulting module name: KERNELBASE.dll, version: 6.1.7601.19110, time stamp: 0x56842600

Exception code: 0xe0434352

Fault offset: 0x0000c42d

Faulting process id: 0x5c8

Faulting application start time: 0x01d15785d06df8f5

Faulting application path: R:\MSDynamicsSL.exe

Faulting module path: C:\windows\syswow64\KERNELBASE.dll

Report Id: 1320cbfd-c379-11e5-9c37-ecb1d73b7cb2

and event id 1026

Application: MSDynamicsSL.exe

Framework Version: v4.0.30319

Description: The process was terminated due to an unhandled exception.

Exception Info: System.NullReferenceException

Stack:

at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()

at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(System.String[])

at MSDynamicsSL.My.MyApplication.Main(System.String[])

I have tried uninstalling and reinstalling the application

removing and reinstalling dot net,

resetting system security

All Suggestions appreciated

Thanks

RayD

  • GabrielSP Profile Picture
    GabrielSP on at
    RE: Dynamics SL 2015 CU1

    Hi Brian, we still running with this issue. Do you have a link to understand better the 36317 bug? i made the process as you describe, but the issue still appear in all clients at the same time. Some time works, sometime not. We create a second app server with a new share and the problem persist. We spent two weeks since the go live and cannot resolve this issue.

    We are reinstalling all clients with your workaround but is this a blocking bug or a share access? because something happend that leave all clients at the same time with the error. Sometimes its solved in matter of minutes, automatically.

    Best Regards

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Dynamics SL 2015 CU1

    The problem is with Windows 8.x or Windows 10 clients handling drive mappings differently than previous Windows versions. The reply posted earlier by Butch has one workaround; that method is summarized below:

    The issue that you are seeing is bug 36317.

    Please edit the following registry key to match the mapped drive:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\DynamicsSL\INSTALLDIR

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\DynamicsSL\ParentDirectory

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Solomon\Solomon IV Tools For Visual Basic\ParentDirectory

     

    Another client install approach is to first map the SL drive using the following steps:

    1. Open a command prompt ‘as administrator’.
     From Windows 8 start menu type COMMAND.
     Right mouse click on ‘Command Prompt’ and select ‘Run as administrator’

    2. Map the drive share
     NET USE S: \\computername\sharename /PERSISTENT:YES

    3. Run setup from the workstation folder
     CD APPLICATION\WRKSTN
     SETUP

    4. Follow the usual prompts

    5. Close the command prompt when completed

    6. Open the command prompt without administrator
     From Windows 8 start menu type COMMAND.
     Select the ‘Command Prompt’ Entry.

    7. Map the drive share
     NET USE S: \\computername\sharename /PERSISTENT:YES

    To verify try running Dynamics SL from the icon places on the Windows 8 menu as well as the Database Maintenance icon placed in control panel/Administrative Tools

    Note: to remove the network mapped drives will require removing both the Administrator privileged and the standard access mappings.

    Mapping the SL network drive in a network login script or group policy would require a similar set of steps.

  • GabrielSP Profile Picture
    GabrielSP on at
    RE: Dynamics SL 2015 CU1

    Hi did you resolve the issue?

    I have same error. I figured out that if i change mapped shared folder to other with the same files (copy pasted and shared) the problem is fixed. but in hours or minutes it start again.

    Any suggestion?

  • Skhosro Profile Picture
    Skhosro 197 on at
    RE: Dynamics SL 2015 CU1

    I am having the same problem with SL2015 and CU1. I had not made any changes to SL. It just stopped working. When you invoke SL it does not come up at all but puts this error in the event log. I have WIndows 10 environment. I think this may have happened on or about September 30th when MS updated windows 10.

    Any help will be appricated

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Dynamics SL 2015 CU1

    I'm seeing this exact problem with the identical Event IDs (1000 and 1026) with SL 2015 CU1 Single User Standard Edition on a Windows 10 workstation.  

    Any suggestions would be appreciated.

  • RayD Profile Picture
    RayD 235 on at
    RE: Dynamics SL 2015 CU1

    This solved the problem

    Thanks

    RayD

  • Verified answer
    Butch Adams Profile Picture
    Butch Adams 4,757 on at
    RE: Dynamics SL 2015 CU1

    This isn't exact, but very close to something I have run into. Check these registry keys and make sure they reference the correct path:

     

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Solomon\Solomon IV Tools For Visual Basic]

    "ParentDirectory"="S:\\"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\DynamicsSL]

    "ParentDirectory"="S:\\"

    "INSTALLDIR"="S:\\"

    Obviously, the S:\\ is going to be the drive where you mapped SL.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\DynamicsSL]

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,995 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,610 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans