Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics SL forum
Unanswered

MR CU9: Encrypted data was invalid and cannot be decrypted.

Posted on by Microsoft Employee

We are moving an install of SL and MR to a test server to upgrade from CU3 to CU9 DDM.  Initial move went well and all the reports check out.  That was the baseline with no upgrade.  After running through the CU9 upgrade we consistently get this error in the service log: 

Encrypted data was invalid and cannot be decrypted.

ERP Validation doesn't report it but it shows in the service log.  Has anyone seen this before?  We have tried many different variations of this upgrade and always get this result. 

Side note, we ran the same test in a clone domain environment.  The original server (clone) upgraded with no issues. 

Thanks,

Categories:
  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: MR CU9: Encrypted data was invalid and cannot be decrypted.

    Follow-up to my own question.  Is there any reason not to just move the SL databases, run a fresh install of MR and not use the MR (non-DDM) database from the previous server so long as we have tbdx of the old report definitions?  Thanks.

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 288,459 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,783 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans