Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics SL forum
Unanswered

System Message 10232

Posted on by Microsoft Employee

I have a client running SL 2011 with many screens developed using the SL SDK.  Until today, all of those custom screens were working fine.  Now, today, every one of them is giving the following error (no matter from what workstation they are launched)

System Message 10232

Assertion failure

File: sqlodbc.cpp

Line 9672

When these same screens are run directly on the SL server they run just fine.  All the standard SL screens open just fine from the failing workstations.

I ran into this one time before and it was related to a Windows Firewall setting that was not allowing outside SQL requests through but, in this case, the Firewall settings do allow sqlservr.exe through and, as I said, the standard SL screens are working.  I tried to temporarily turn off the Firewall but that did not make a difference.  The user and their IT people claim that no changes to the workstations or the server were made yesterday but, obviously, something changed.

So, my first question is if anyone has run into this before and found the cause.  Remember the standard SL screens are working, the custom screens were working up to day and work on the server and no changes have been made to the custom screens.

My second question is whether anyone knows why screens developed using the SDK work differently, in some fashion, from Microsoft developed SL screens?

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: System Message 10232

    I had this happen on a 2015 CU2 install recently on a laptop.  Just regular SL programs failing and not ones that were customized.  There is a recommendation out here that you need to stop and restart SQL services.  Sounded very strange to me but at this point I was stumped.  Tried it and suddenly the client is working.  Thanks for that.

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: System Message 10232

    Found the issue but not sure what happened.

    I checked the services on the SQL Server and all the SQL services that should be running were.  However, I restarted the sql server browser and that resolved the issue.

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 288,420 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,672 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans