Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics SL forum
Unanswered

SL 2011 FP1 Customized Report Record Sorting Problem when using Load Template

Posted on by Microsoft Employee

Hi Everyone

I had customized a Statement report by crystal report, when i use solomon to preview the report, if print normally will be correct, but if i load template and print it, the sorting will be wrong. If after i load the template and i press reset in the sorting tab, the record will sort in order.

Thank you.

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: SL 2011 FP1 Customized Report Record Sorting Problem when using Load Template

    I have the same issue.

    In SL 2011 report.

    Thanks,

    Chuck

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: SL 2011 FP1 Customized Report Record Sorting Problem when using Load Template

    Hi Butch Adams

    I had tried to save the template again after reset the sort order, but the result are still the same.

    Thank You

  • Butch Adams Profile Picture
    Butch Adams 4,757 on at
    RE: SL 2011 FP1 Customized Report Record Sorting Problem when using Load Template

    Have you tried resetting the sort order and then saving the template again? Sounds like the template got saved with a custom sort order.

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: SL 2011 FP1 Customized Report Record Sorting Problem when using Load Template

    Hello Carolyn,

    Actually there are no changed of sort criteria during the report print.

    There are few scenarios that I had tried, but all scenarios are having problem. And below was my setting in crystal report

     

     

    Scenario 1:

    When I use the above setting, when I print report with filter from roi and without loading template, it has no problem. But when I save my setting to the template and print it again by loading the template, the record will print without any sorting.

     

    Scenario 2:

    I delete bit A – AR08600_wrk.Doctype, and A – AR08600_wrk.ARDoc1_DocDate sorting in crystal report, the report will show correct sorting for AR08600_wrk.Doctype but A – AR08600_wrk.ARDoc1_DocDate will not sort in order. It take effect on both normal print and print with template.

  • RE: SL 2011 FP1 Customized Report Record Sorting Problem when using Load Template

    Hello Kuan,

    The report most likely has default sort criteria which is conflicting with the changes you made to the sort tab.  Can you describe the changes you are making to the Sort tab?

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 288,459 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,783 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans