SBX - Search With Button

SBX - Forum Post Title

Deployment failed from LCS

Dynamics 365 for Finance and Operations Forum

Shahrukh Naeem asked a question on 17 May 2018 4:55 PM
My Badges

Question Status

Suggested Answer

Hi everyone,

I am facing an issue while deploying packages from LCS in DevTest VM. The same packages are deploying fine on UAT.

Deployment failed everytime on Preparation step. And when I download the logs, 0 KB file downloaded and nothing shown in that file.

Reply
Ada Ding responded on 17 May 2018 7:16 PM
My Badges

Hi,

When did this happen? Did this happen after you selected the package and clicked "Apply"?

Is the Runbook generated?

Have you tried to log into the VM to see the issue?

Reply

Hi Shahrukh,

Were all applications and above all was Visual Studio shut down during the deployment? Ensure all running applications are shut down before starting the deployment.

Reply
Shahrukh Naeem responded on 18 May 2018 2:02 AM
My Badges

Hi  Andre,

Yes all application were shutdown at the time of deployment, and even I restarted the machine before starting deployment.

Hi Ada,

Yes, this happened when I selected the package and applied it. It went in progress and then after some time it given error that Preparation Failed.

Runbook is not generated. And i checked the logs in VM, nothing appeared in the execution log.

Reply
Nikolaos Mäenpää responded on 18 May 2018 2:04 AM
Suggested Answer

Have you happened to change the password of the local administrator of the VM?

Reply
Marija Todorovic responded on 18 May 2018 11:14 AM
My Badges

Maybe you do not have space on the disk. Please check.

Usually when space is missing you do not get any meaningful error.

Reply
Nikolaos Mäenpää responded on 18 May 2018 2:04 AM
Suggested Answer

Have you happened to change the password of the local administrator of the VM?

Reply

SBX - Two Col Forum

SBX - Migrated JS