Field 'Lot Id' Must Be Filled In When Trying To Update Project Quotation Line

Question Status

Suggested Answer
SergiPB asked a question on 22 Mar 2013 1:51 PM

Good Day,

I am receiving the infobox "Field 'Company' must be filled in" and "Field 'Lot Id' must be filled in." when I try to update a line in a project quotation for anything other than transaction type of Item.

All required fields are set correctly as far as I can tell, can anyone point to me where this would be set.


Suresh Kotapalle responded on 22 Mar 2013 4:06 PM

By any chance are you creating the quotation using template? If so, this is due to a bug which got fixed. See KB article 2756645 for more details.

Ali Barada responded on 14 Jan 2014 1:42 AM

hello, i am facing same issue. did you find the soluion?

P.S: can't find the KB article

Tom Van Dyck responded on 15 Jan 2014 3:38 AM

try this link:

Ali Barada responded on 21 Jan 2014 4:06 AM


I am not able to install the HotFix on the AX Server it is giving me:

Exception: System.ArgumentNullException

Message: Value cannot be null.

Parameter name: collection

FullText: System.ArgumentNullException: Value cannot be null.

in the setup logs but that is a different issue. I need to pass the company and lot id issue, any ideas?

JennyColey responded on 2 Oct 2014 5:01 PM


Were you able to resolve this? I am getting the same error on purchase lines even though the lot id and datareaid fields are specified.



Uday-AX responded on 3 Nov 2014 5:40 AM

Hi Jenny,

I am also getting the same error in purchline where I have inserted the lines from purch agreement release order. Could you have any idea please..... if it's a bug how the above KB will fix as it was for different table.....

thanks for your help



jordan prapant responded on 9 Apr 2015 5:00 AM

Hello Jenny, Uday,

Have you finally found an explanation to this? I found out that the system is behaving randomly on this error. My purchline is sometimes getting this error via different triggers and I have no idea why or how to resolve it.

Did you find the reason or a workaround for this?

Best regards,


Casey Clifford responded on 14 Aug 2015 7:52 AM

I have this now too.

Field 'Company' must be filled in.

Field 'Lot ID' must be filled in.

I'm just trying to add a line to a Purchase Order

Bhaskar Roy responded on 14 Aug 2015 8:09 AM

Hi Casey,

Could i get more info and AX application version and kernel version number.



Casey Clifford responded on 14 Aug 2015 8:16 AM

Sorry, I'm quite the newb for now, how might I go about finding this information?  

Bhaskar Roy responded on 14 Aug 2015 8:21 AM

hope you have generated number sequnce wizard.

Goto -> right top ->icone (?) -> aboute microsoft dynamics.

Casey Clifford responded on 14 Aug 2015 8:27 AM


Kernel version: 62.10002473

Application version: 6.2.IDDO.1437

Bhaskar Roy responded on 14 Aug 2015 8:55 AM

It looks ok. when are you inserting the record in purchline can you put the debugger in purchline table insert method and check inventransid is getting generated through number sequence and set in into inventrans field.

carsz responded on 18 Aug 2015 4:42 AM

We had the Lot Id error on a Project Quote when we tried to confirm it. We figured out that this error only happened after we did a revision on the quote. If we confirm a quote without having made a revision on it it doesn't give us the error.

Suggested Answer
Suggested Answer
Suggested Answer
Georgiev responded on 21 Jul 2017 4:12 AM

I had a similar case while creating purchase line for Purchase order.

The reason was that there is no record in PurchLineForeignTradeCategory table related to PO line added.

What helped me resolve the issue - Created a record against the PO line causing this error in the PurchLineFroeignTradeCategory table in the integration and the error disappear.