can.t have unallocated cost on planning formula AX2012

This question has suggested answer(s)

I have made an inventory closing and I got this error message:

can.t have unallocated cost on planning formula

It only tells me the item number that has the error, not the transactions.  There are many transactions on this items.  Did anyone had this message in the past and what was the solution to solve the problem.

I cannot cancel the closing, the button is not available, I can only resume the inventory closing once the problem is corrected.  In the mean time many transactions are blocked which is crucial.

thanks

All Replies
  • In your formula you have a by/co product with the cost allocation not set, you need to set it.

    Steve Weaver | Dynamics AX Solution Architect - UK | My Blog

    This forum post is my own opinion and does not necessarily reflect the opinion or view of my employer, Microsoft, its employees, or other MVPs.

  • Hi,

    i have the same error but when i am trying to recalculate the inventory, and i don't have anything in the formula form!!

    but when i click on resume calculation button several times, it resumes every time till it gives me the correct sign

    can anyone help me please ASAP??!!!

  • Hi,

    I have the same issue, however, in our environment we do not have any formulas.  

    Did anyone resolve this?

  • The message only appears and is referenced by a Formula - can you check the tables for data? Failing that you would need a developer to debug, because the message is being called incorrectly by another issue.

    Steve Weaver | Dynamics AX Solution Architect - UK | My Blog

    This forum post is my own opinion and does not necessarily reflect the opinion or view of my employer, Microsoft, its employees, or other MVPs.

  • Thank you for your fast response.  

    I have checked all the tables and all the ones that are pmf or pds related are all blank.  Also, the formula table is blank too.  Would you be able to suggest any other tables?  

  • I would suggest a developer debug the message to tell you the table that is causing the error to be called, it is not the one you would expect - although you may want to look in the equivalent of the ProdBOM where a formula could be attached to a batch order, but I do not know the name of the table. Otherwise you have covered the obvious so we would need guidance.

    Steve Weaver | Dynamics AX Solution Architect - UK | My Blog

    This forum post is my own opinion and does not necessarily reflect the opinion or view of my employer, Microsoft, its employees, or other MVPs.

  • U r applying formule on Planning Item rather on formule item

  • I see something similar in our system and just ran it briefly through the debugger.

    It appears that the item that produces the error is not included in the table InventTransOriginAssemblyComponent, which should contain information on all assembled items and their components.

    Basically it is trying to find the item that this part belongs to.

    In the item setup I notice that the item does not have any production type. This does seem to constitute a planning item in the code.

    Like shivrav says, the solution could be as simple as selecting a production type for your item.