Upgrade Task issue with CU6 (AX2012 R2)

Question Status

Suggested Answer
mharsh asked a question on 16 Jul 2013 12:11 PM

Hello Everyone,

Just let me say I am fairly new to AX so I am a little green still. All of our environments are brand new AX 2012 R2 installs. All on Server 2012 STD with SQL 2012 and SH 2013. All updated and patch.  Only data we have is the demo data and no mods at all at this time. It is all plain vanilla.

I recent installed CU6 to fully fix the issues when using SharePoint 2013 as the EP server. Installing the update on our Development environment, everything went through fine up until second to last part of the software update checklist. The Data upgrade cockpit list all the upgrade task and when I would start it, it create the batch to run the scripts according to my batch group, but would never start. I even let it sit for 48 hours and still no go. No errors either.

So after trouble shooting, I have discovered the issue. Somehow it has created all the individual upgrade tasks with a start time of 12:00am and end of 12:00am which is not allowing the tasks to start in the batch. I cannot find anywhere I can alter these times. I also cannot find anywhere in the AOT to modify these setting.  I changed to allow modify to Start/end date for the Batch in the AOT but it would not let me change the Task times.

Also as a test to see if it was one time glitch in the Dev environment. I applied the update to our QA environment which is an exact copy of the Dev and the same thing happened. All the upgrade task showed with 12:00am as start and stop time and I can't change.

So anyone can throw me a bone here I would greatly appreciate it.



Tony Wan responded on 16 Jul 2013 12:56 PM

Have you checked whether AOS is enabled with batch? In addition, check the batch group is assigned to the right AOS server.

If the batch job is running then obviously you see the batch job history with details

mharsh responded on 16 Jul 2013 1:24 PM

Yes, the batch groups and AOS batch servers were already configured on both environments before installing CU6. We had been testing and running batches already for training.

Also something else I just noticed is that all of our previously created batch jobs are also now set to the 12:00am start and stop time which before the update. They were set to the time configured for the batch server schedule and  group.

mharsh responded on 16 Jul 2013 1:30 PM

Also on this, it isn't the batch jobs I am having a problem starting. I can get the batch jobs to run but the upgrade task that are created from the Data Upgrade Cockpit are what is the problem.

When I run the data upgrade, it creates a batch job containing all the upgrade tasks which are what is set to 12:00am start/end. The batch job will say executing, but will never start the tasks because all the task are scheduled to start at 12:00am and end at 12:00am causing then to never start. Any other batch job I create runs and completes just fine.

Tony Wan responded on 16 Jul 2013 3:26 PM

As you mentioned the data upgrade job does show the status of executing so i would assume the batch job does run. Just an idea, can you setup the debuggger on the data upgrade batch job for some investigation?

Tony Wan responded on 16 Jul 2013 3:27 PM

Another concern, have to try to do a full compile in your environment? Sometimes, if the object doesn't get compile then the process might just freeze.

mharsh responded on 16 Jul 2013 4:27 PM

As far as the full compile, I followed the Software update checklist which goes in the order of, Compile Application, Detect Code upgrades, Compile into .Net CLI, Restart AOS, Detect update scripts, Presync Database, Sync Database, and to where I am stuck now Launch Data upgrade.

So is there another compile I need to do other than what I have already performed?

I have not done a full Debug on the batch process yet but the batch isn't the problem. It is the task in the batch. There are 127 task in the batch and all the task are set to start and end at 12:00 am this is preventing the individual tasks from starting.

If there was a way that I could change or modify the tasks set start and end times. That would fix my problem. The issue is I cannot find any where in the AOT to allow me to modify this setting. I have modified the batch settings to allow me to change the time on the fly but it will not let me change the tasks time.

Tony Wan responded on 16 Jul 2013 5:59 PM

You can try to modify the start time for the specify job under the table BatchJob in SQL server or AOT

mharsh responded on 17 Jul 2013 11:07 AM

Yeah that is what I already have done, but I run into a small issue. So this is what is happening.

The Upgrade Cockpit creates the batch and starts the batch as soon as you tell to do the updates. After editing the BatchJob in the AOT I can modify the time in the individual update task now but the problem is AX throws an error and says you can't modify the object while batch is in its current state. So you have to stop the batch to allow you to update the times but when you try to rerun that batch from the Batch Job Window, it says it is no longer valid. This is caused by the batch being created by the upgrade cockpit and once you stop it requires to restart from the upgrade cockpit and in turn creates a new batch and around and around you go.

What I really need is a way to modify the individual task start time while in the upgrade cockpit before the batch is created. I have yet to find a way to do this or even find where the individual task are stored to try to hack them with right time.

I have also tested and verified on test batch jobs with internal batch task that having the start and end time set to the same time will stop the batch task from running in the batch job. It appears again in my awesome luck I may have found another strange glitch in a Microsoft update.

mharsh responded on 31 Jul 2013 1:14 PM


So I finally found a way to change the Start and End time to the Upgrade task but the task still will not run. The upgrade batch says it is Executing but noting happens. (left it sit for 48 hours).

At this point I am completely lost on what to look at next so if anyone has any suggestions. Please toss them my way.

Leo Fox responded on 31 Jul 2013 5:10 PM

Hi I have experienced the same issue when doing R2 upgrade to CU6, and tried everything you tried, all in vain.

The scripts finally unfroze and got executed all of a sudden, and I struggle to tell what exactly was a bottle neck before. Anyway, at the time of successful execution the following desperate steps were in place:

I re-compiled, re-synced with DB, re-generated CIL to make sure that no errors whatsoever were reported on the way,

AX server was running with my own credentials, more permissive that Network Service,

I was logged in and ran AX as a domain administrator on "initial" partition,

batch server was configured to cover the whole day, with all cache limits greatly increased...

I have no idea which of the above helped, but it surely did.

Good luck!

mharsh responded on 31 Jul 2013 5:14 PM

Oh good, I am not the only with bad luck. By chance could you tell what you have set for the Cache settings in hopes that may be a factor.

Leo Fox responded on 31 Jul 2013 5:25 PM

Don't remember exact numbers, but most likely I just multiplied everything by 10

Richard at HTI responded on 1 Aug 2013 9:25 AM

I have exactly the same problem and I just checked back in to see if you had found anything. I see the answer above posted on August 1st. Really curious but this seems like a lot of work to do when this should work right out of the box.


mharsh responded on 1 Aug 2013 4:00 PM

So I recompiled the system today as suggest and it through up this error

"Cannot edit a record in LastValue (SysLastValue).

An update conflict occurred due to another user process deleting the record or changing one or more fields in the record."

I tried looking for SysLastValue and can't find it anywhere and there are not other users on the systems besides me so I don't really know if this is important or could be ignored.

Anyone have any suggestions?

Leo Fox responded on 1 Aug 2013 10:53 PM

not sure, sounds quite harmless to me,  but you may want to try just deleting SysLastValue entries in the Usage data anyway:

in AOT\Forms open SysLastValue form,

select the row where Element name is SysLastValue and delete (Alt-F9)

Suggested Answer
Vasilis Giannopoulos responded on 8 Aug 2013 4:40 AM

I had exactly the same problem and, as everyone, I tried every option that was suggested here without any result. What did the trick for me were the following:

a) First of all there were some scripts that were referring to the companies EXT and COM which did not exist in the legal entities. So I disabled those scripts.

b) Those scripts had batch constraints to or from other batch tasks. So I went into the BatchConstraints table, I made the BatchId field visible and I removed any constraints that had to do with those, now disabled, scripts.

c) Still, after that I found out that only the scripts that were referring to partition "initial" were finished, while the rest were still at status "ready". The reason was that my user had only one record in the UserInfo table and that was for the "initial" partition. For the rest of the partitions there were no records. When that was fixed, the rest of the scripts were executed normally.

Suggested Answer
mharsh responded on 8 Aug 2013 9:14 AM

Hello Everyone,

So after a lot of experimenting and working our ISV, we found what had caused this issue. If you have a system that has used the demo data from Microsoft and you imported the data and the model store. It will cause this issue. There is a problem within the demo data model store from Microsoft that may cause strange issues with CU6 and we found it even caused issues with even CU1.

We had attempted every given fix that we could find for this issue and none of them worked for us. So we decided to redo our environments from scratch and see what would happen. We installed CU6 right out the gate with no demo data. Once the initialization was complete, we then imported only the Demo data without the model store and everything is working as it should.

Just FYI, we ran through our test several times and not every time did the CU6 update cause a visible issue within our system but we always had issues after applying it in one form or another. So you might want to wait to see if Microsoft will release an updated version of the demo data. Also they have already released a fully updated CU6 Demo VM if you need it on Customer Source. (Not showing up on Partner Source for some reason)  

Suggested Answer
mharsh responded on 3 Dec 2013 4:14 PM

Unfortunately, I never found a fix for this issue and had to resort to a complete wipe of both our DEV and QA environments.

I did find a workaround  that work for us and it was to download the VM Demo image and pull the Demo database from the updated VM image that has CU6 already installed. It was not simple or quick but it did work for us and allowed us to get through our testing and development. The only problem with this is you need to then download and install the update for the task recorder to make it work properly.

Task Recorder update: support.microsoft.com/.../KBHotfix.aspx

We tried several times with the demo Contoso data and every time resulted in the same issue with the update batch getting stuck and could never proceed.

Suggested Answer