A posting rule is not defined for the earning code error

This question is not answered

Hello, I got this error "A posting rule is not defined for the earning code. Create the posting rule on the  Accounting tab of the earning code." when trying to release Earning statements for workers, however I already setup Positing rule for all earning code, any suggestions please?

All Replies
  • 1) Click Payroll > Periodic > Earnings statement processing > Generate earnings.

    Note

    To generate earnings from the Workers or Positions form, click the Payroll tab.

    2)In the Pay cycle field, select the pay cycle of the worker positions to process.

    3)In the Pay period field, select the pay period for the worker position earnings. The pay periods displayed are available for the pay cycle. The first open pay period is the default pay period, but you can select any open pay period from the list.

    4)Click OK to generate earning statements. A message is displayed to indicate that the earnings statements were generated successfully.

    Note

    Recurring earnings and the earnings from schedules are created first because salary amounts might be affected by other earnings that are automatically generated.

    Close the form. To view the earnings statements that were created or updated, open the Earnings statements list page.

    --

    Thank you
  • Thanks Umesh for your reply, but i already generate earnings, I have an error in releasing the generated earnings.

    I opened the earning statements form then check one of the generated earning statements then click the release earning statement then i got the error.

    "A posting rule is not defined for the earning code. Create the posting rule on the  Accounting tab of the earning code." when trying to release Earning statements for workers, however I already setup Positing rule for all earning code

    any suggestions please?

  • Do you have an Account structure defined in the Ledger in General ledger? If yes, the G/L account which setup in Posting rule must be consider in the Account structure as well.

    I've encountered the same issue and got it resolved. Hope it works for you too.