DAX 2012 R2 stuck on Installing model 'Foundation' to the database

Question Status

Tarcisio Gambin asked a question on 11 Dec 2013 11:11 AM

Hi All!

I'm starting to configure a new DAX 2012 R2 environment that has the following topology:

  • 01 AOS Server
  • 01 Failover clustered SQL Server
  • 01 SharePoint WFE (Enterprise Portal / PWA)
  • 01 SharePoint App (Project Server integrated with DAX)

By installing and configuring SharePoint and Project, everything goes well (using the same database instance will be used for DAX).

The problem is when I'm start to configure DAX 2012 R2 Databases. Setup stuck on the following step:

I tried to stop and start it again... But its keep running during many hours! I also tried to run the setup by calling local (C:\DAX\setup.exe) and by network share (\\servername\dax\setup.exe). Any result...

Already disabled UAC, reboot the server and the problem remains... Look at these details:

No CPU, memory and network usage during the setup...

Apparently, the model (Foundation) is not found and being imported to SQL. The log (and setup) stops here...

The last message on SQL Server Event Viewer is about Dynamics. No errors, warning or success advices...

The user account I'm using for install databases has the following permissions:

  • Local admin on DAX/ AOS Server
  • Local admin on SQL Server
  • SYSADMIN role on SQL Server

Is there anything else I'm missing?

Thanks all your help!

André Arnaud de Calavon responded on 11 Dec 2013 11:46 AM

Hi Tarcisio,

You can download an installation manual with all related information here: www.microsoft.com/.../details.aspx.

You can also check all system requirements if your environment meets the supported hardware and software: www.microsoft.com/.../details.aspx

Installation of the Foundation is a long running task. If you stopped it, I wonder if it really was stuck. Hours is probalbly too long. Have you monitored the discs and network during installation as well (next to the cpu and memory)?

Please check the two documents if you can find additional information and requirements as I don't know your complete details about servers, operating systems and security policies.

By the way... This link on technet provides an complete overview on the required permissions for installing AX2012 and the components: technet.microsoft.com/.../aa496457.aspx

Tarcisio Gambin responded on 11 Dec 2013 12:36 PM

Hello Andre! Tks for your quickly answer =]

Let's begin:

- I already followed these 2 documents to create 2 environments earlier (Homolog e QA), and they were completed sucessfully. It's strange that the same procedure used before is resulting this problem...

- The hardware that I'm using is better than that used on these environments I did. The base software is an Windows Server 2008 R2 SP1 and SQL Server 2008 R2 SP1. Just for information, this database already has databases of another DAX 2012 (non R2) instance, so I suppose that's isn't related to software version.

- About canceling the installation, I did it because it has more than 2 hours without any hardware usage and logs related on Event Viewer during the setup. Those environments I mentioned didn't delayed more than 10 minutes each to create databases.

- About the CPU, Memory, Disk and Network, I can see that's really working during the first 5 minutes (when the messages recorded on Event Viewer and installation log shows that foundation model was imported sucessfully). After that, setup freezes.

- About permissions, I'm a really follower of least permissions principle, but in this exception I already set the installation account as Local Adm of SQL and AOS Server, also with a SYSADMIN role...

Is there anywhere I can find more detailed log messages about transactions (like ULS Logs from SharePoint)?

Thanks a lot!

André Arnaud de Calavon responded on 11 Dec 2013 12:48 PM

Hi Tarcisio,

You can eventualy check the event logs on the servers. Also SQL has an additional own log (Node Management in your Database server connection).

Can you also try to install with Domain admin rights?

Tarcisio Gambin responded on 11 Dec 2013 1:17 PM

By starting the setup again, I'll detail the situation by the following prints:

CPU/Memory on starting database configuration Network usage on starting database configuration
CPU/ Memory after sucessfully importing of Foundation model Network usage after sucessfully importing of Foundation model

The event viewer keeps in wonderland on Database and AOS Server that I'm runing this setup =/

The DAX instalattion log files has in the last lines:

Model Foundation (Microsoft Corporation) not found.
Importing file 'E:\DynamicsAX2012R2Setup\dynamicsax\Models\Standard\Foundation.axmodel' to the database 'DBInstanceName\PROD_DAX2012R2_model'.

Any suggestion will be appreciated =]

André Arnaud de Calavon responded on 11 Dec 2013 2:02 PM


Can you try to get new installation packages? It might be a corrupt file or limitation within the length of a filename including the path. I always try to have the root setup folder name as short as possible as I had problems in the past on installing AX when the setup files were in a lower structure of certain directories.

Tarcisio Gambin responded on 11 Dec 2013 2:59 PM

I'm not sure about the long path - I ran the same path at the others servers and worked well.

I also tried to copy and 'unpack' the original ".iso" file I have on a network share and the problem persists.

I'll try to download it again, and if it's possible, to ge a checksum =]


Dominic Lee responded on 11 Dec 2013 7:19 PM


Just throwing my 2cents here. Below is the log of a DB installation for AX I did awhile ago.

2013-10-22 13:08:51Z    Model Foundation (Microsoft Corporation) not found.
2013-10-22 13:08:51Z    Importing file 'F:\Models\Standard\Foundation.axmodel' to the database '<server>\DAX_model'.
2013-10-22 13:08:51Z    Model Foundation Labels (Microsoft Corporation) not found.
2013-10-22 13:08:51Z    Importing file 'F:\Models\Standard\Foundation.axmodel' to the database '<server>\DAX_model'.
2013-10-22 13:08:51Z    Importing file 'F:\Models\Labels\FoundationLabels.axmodel' to the database '<server>\DAX_model'.
2013-10-22 14:55:59Z    Model import complete.

- The setup Log will stuck at the "Import file xxxxxx " message until the model import is completed.
- It took close to 2 hours to import both the foundation and foundationLabel models in this run. This server is on Windows Azure and I assume there is no hardware/network issue there. Maybe you can give your installation an extra hour or two and see if it gets done?

On the other hand, I have an experience at a client site that the installation took much longer. It was later confirmed that there is some problem with their network/SAN setup. (I wasn't informed about the details, they moved on to different hardware to solve the issue).

P.S. In case you just want to get things running at this moment. You can make use of the clean DBs you get from your other installations. Backup the DBs and restore them in the target SQL instance.

Kind regards,


Tarcisio Gambin responded on 12 Dec 2013 2:54 AM

Thanks for your suggestions Dominic!

It's strange that the others environments had completed this step without any problem. The same OS, same setup files and improved hardware. Except by the database instance I'm suspecting... That's the only difference.

By the way, the last setup I started is running in more than 12 hours =[

Best regards

Tarcisio Gambin responded on 12 Dec 2013 3:18 AM

About the backup/ restore from other environments, I'm not sure about that.  Is there any reference to other hosts on databases that I will need update?

I'm thinking that it can cause future problems, when an environment can refers databases from others environments.

Tarcisio Gambin responded on 12 Dec 2013 4:59 AM


The main problem is related to the SQL Server Instance, because I tried to use another (also Shared) instance and the Database Setup was done fine (less than 15 minutes)!

Now I'll try to install AX Databases at the intended database instance again and follow it on Management Studio by sp_who2 and sp_lock.


Dominic Lee responded on 12 Dec 2013 6:26 PM

Nice to know that you are making progress. =]

As for restoring DAX database from one environment to another, it's a procedure that many AXers do from time to time. One common scenario is to create a copy of the production environment as testing environment. A document is available in the blog post below which discuss the configuration steps needed after restoring an AX database to another environment.




Tarcisio Gambin responded on 13 Dec 2013 7:22 AM

Hi Dominic!

Thanks all your help again! I'll take a look on the documentation and reply as soon as I can!

Of course this procedure will not solve the root cause (database instance) of the problem, and I'm concerned about other setup tasks related to DAX Configuration - like Compilation and Sync Databases on DAX Client.

By the way, I'm talking to the database guys to see if there's something new!

Best regards,

Cristian Bordino responded on 2 Apr 2014 12:50 PM

Hi Tarcisio,

i wonder if you have some news about your problem.

I am now stuck on the same problem: after 10 hours the application remains on "installing model 'foundation label' on database".

During this process i can't see any activity like crud statment on sql server (through activity monitor) neither on task manager (cpu/memory/disk not "stressed").

After killing the installation, database

- MicrosoftDynamicsAX_model has about 3Gb data

- MicrosoftDynamicsAX has about 2Gb data

For info, i am trying to create a developer enviroment with

- Ax 2012

- Windows 2012 Server

- Sql Server 2012 Express with Advanced Services

- SharePoint Foundation 2010

Thank for any help,


Tarcisio Gambin responded on 2 Apr 2014 2:06 PM

Hi Cristian!

As this project had a short go-live remaining time, and the SQL Server responsibility was under databases administrators, we didn't have enough time to finish the troubleshooting.

We had finished this environment using another SQL Server, single server not mirrored.. (the original scenario covers an SQL Server using database mirroring).

It was not so clear to me, but I really suspect about the network/ SQL Mirroring configuration...

I hope you really can finish this thread, and if it's possible to share it with us :D