Question Status

Verified
Jali asked a question on 6 Mar 2015 2:08 PM

Dear AX Dynamics Expert,

Greetings!!!

I've a problem regarding the installation of Visual Studio Tools from AX Installer.

My AX version is 2012 CU3 RTM (6.3.164.0).

This is the pre requisites error:

If I clicked the pre requisite "Required updates for Microsoft Visual Studio 2010", here is the suggestion link:

http://go.microsoft.com/fwlink/?LinkId=215027

I've downloaded the iso file from that link and here is the iso file name "VS2010SP1dvd1".

When I clicked the setup button from this iso file, here is the screen that I got:

I assume it is because I've not yet performed the installation of Microsoft Visual Studio 10 RTM version, so the SP1 version cannot be ran.

So I downloaded the RTM version of Microsoft Visual Studio Express 2010 and here is the iso file name "VS2010Express1".

I've installed one of visual studio tools, which is Microsoft Visual C# Express 2010 from the iso file and successfully installed.

The I ran again "VS2010SP1dvd1" and now I was able to continue with the installation process:

And finally SP1 package has now being applied:

Now you can see the version from Microsoft Visual C# Express 2010 has already been changed:

But when I validated again, it showed me the same error.

How can it be?

Please really need your advice.

Thank you.

Best Regards,

Jali

Reply
Suggested Answer
Joris de Gruyter responded on 6 Mar 2015 2:18 PM

You can't use the free version of Visual Studio ( = Express). Check the system requirements for AX 2012, you need at least visual studio 2010 pro license. Also remember R3 now uses Visual Studio 2013 instead of 2010.

Reply
Jali responded on 6 Mar 2015 2:30 PM

Hi Joris,

I've already read "AX2012SystemRequirements.pdf" file and I think for AX 2012 R3 RTM version, we still can use Microsoft Visual Studio 2010. Here is the screen capture of the pdf file:

How can I get Microsoft Visual Studio 2010 Professional Edition, Premium Edition, Ultimate Edition, or Team Edition?

Please need your advice

Thank you very much.

Best Regards,

Jali

Reply
Suggested Answer
Denis Macchinetti responded on 6 Mar 2015 2:56 PM

Hi Jali

You must have an MSDN Subscription.

Take a look at www.visualstudio.com/.../msdn-subscriptions-vs.aspx

Temporarily, you could use the trial edition for 90 days.

Thanks & Regards

Denis Macchinetti

Technical Architect

Respect the provided answers from other community members. Don't provide or do not copy the same answer to the same thread. Additional insights are welcome!

Reply
Jali responded on 8 Mar 2015 3:28 AM

Hi Denis,

Thanks for your help.

I've downloaded Microsoft Visual Studio Ultimate 2013 ISO trial version based on your suggestion link and the file name is "vs2013.4_ult_enu.iso".

Then I installed this Microsoft Visual Studio Ultimate 2013 ISO trial version in my desktop.

After the installation, I ran AX installer again to perform Visual Studio Tools installation.

But the same error appeared:

I'm very very confusing about this. So many Microsoft Visual Studio I've downloaded and installed, like

* Express 2010 (VS2010Express1.iso),

* Test Professional 2010 (X16-42549VS2010TestProTrial1.iso),

* Express 2012 (VS2012_WDX_ENU.iso)

* Express 2013 (vs2013.4_dskexp_ENU.iso),

and the last one is Ultimate 2013 (vs2013.4_ult_enu.iso),

but nothing work, always stuck in above pre requisite.

Please realy need your help.

Thank you.

Best Regards,

Jali

Reply
Verified Answer
Martin Dráb responded on 8 Mar 2015 3:55 AM

Version 6.3.164.0 is AX 2012 R3. You need Visual Studio 2010 for this version. Nevertheless if you can choose, don't start with the old version of AX - install AX 2012 R3 CU8 and then use VS 2013 instead of VS 2010.

Martin "Goshoom" Dráb | Freelancer | Goshoom.NET Dev Blog

Reply
Jali responded on 8 Mar 2015 6:03 AM

Hi Martin,

Thanks for your response.

I am still using version 6.3.164.0 and I prefer to install Microsoft Visual Studio 2010.

I've installed Microsoft Visual Studio Team Explorer 2010 in my desktop and applied the license.

After that, the installation of Visual Studio Tools worked fine.

The previous issues that I've got are related to unmatch Microsoft Visual Studio version and license problem.

Thanks for your help.

Best Regards,

Jali

Reply
Verified Answer
Martin Dráb responded on 8 Mar 2015 3:55 AM

Version 6.3.164.0 is AX 2012 R3. You need Visual Studio 2010 for this version. Nevertheless if you can choose, don't start with the old version of AX - install AX 2012 R3 CU8 and then use VS 2013 instead of VS 2010.

Martin "Goshoom" Dráb | Freelancer | Goshoom.NET Dev Blog

Reply
Suggested Answer
Joris de Gruyter responded on 6 Mar 2015 2:18 PM

You can't use the free version of Visual Studio ( = Express). Check the system requirements for AX 2012, you need at least visual studio 2010 pro license. Also remember R3 now uses Visual Studio 2013 instead of 2010.

Reply
Suggested Answer
Denis Macchinetti responded on 6 Mar 2015 2:56 PM

Hi Jali

You must have an MSDN Subscription.

Take a look at www.visualstudio.com/.../msdn-subscriptions-vs.aspx

Temporarily, you could use the trial edition for 90 days.

Thanks & Regards

Denis Macchinetti

Technical Architect

Respect the provided answers from other community members. Don't provide or do not copy the same answer to the same thread. Additional insights are welcome!

Reply