SBX - Search With Button

SBX - Forum Post Title

Realized consumption and cost amount is blank only for material overheads in price calculation form

Microsoft Dynamics AX Forum

Karthik asked a question on 10 May 2019 6:23 AM

Question Status

Suggested Answer

Dear All,

I am getting one issue in production order >> price calculation form.

Realized consumption and Realized cost amount is showing as blank only for material overheads. but for the same material overheads estimation consumption and cost amount is calculated properly.

Due to the above issue, FG price is coming wrong/less.

Can any one share input to fix ?

  

Reply
Suggested Answer

Hello Karthik,

How is the calculation of the overhead defined?

Can you check this in the setup of the costing sheet?

Is it possible that the % amount is set to 0?

Best regards,

Ludwig

Reply
Karthik responded on 10 May 2019 7:33 AM

Hi Ludwig,

Thanks for the response.

In costing sheet, i have defined 7% for calculation. As per that, estimation amount is calculated properly. PFA screenshot of costing sheet.

Regards,

Karthik

Reply
Karthik responded on 10 May 2019 10:23 AM

Hi All,

Anyone can share input? Reconfigured costing sheet and tried with new production order. still unable to get realized consumption and cost amount for material overheads.

Have you faced this issue ?

Thanks.

Reply
Suggested Answer

Hello Karthik,

Do your sub-Boms (F-RM1, ... F-RM3) have cost prices setup in the costing version STD?

Are those sub-Boms assigned to the material and/or manufacturing cost groups?

Best regards,

Ludwig

Reply
Karthik responded on 10 May 2019 11:20 PM

Hi Ludwig,

Yes. I have defined standard cost for bill of material components (RM1...RM3)

Cost Group: In item master, by default it filters only the cost group with cost group type material..

Yes. Material based cost group is attached for raw materials in item master...

Thanks.

Reply
Suggested Answer

Hello Karthik,

Can this be a date issue?

I noticed that your overhead is active from 10 May.

Has the production order been recorded and posted before the date the overhead % value was active or valid?

Best regards,

Ludwig

Reply
Suggested Answer

Forgot to mention:

Also try if you can enter a site specific overhead in the costing sheet to see if this makes a difference.

Best regards,

Ludwig

Reply
Karthik responded on 14 May 2019 5:07 AM

Hi Ludwig,

Thanks for the update.

Yes. Currently i have configured site specific costing sheet. Also created new production order and checked in price calculation form, after posted picking list journal in production order.

In Production order, picking list journal lines and costing sheet we used the same site.

Screenshot:

Regards,

Karthik

Reply
Karthik responded on 14 May 2019 5:29 AM

The realized consumption and cost amount is not updating only for material overheads.

Regards,

Karthik

Reply
Karthik responded on 14 May 2019 10:55 AM

Dear All,

Is there any other setup missed / causing this issue ?

Anyone faced this kind of issue ?

Regards,

Karthik

Reply
Suggested Answer

Hello Karthik,

Have you actually saved and activated the costing sheet through the buttons on top?

What I do not know is whether the production order that you processed has material costs included.

Material costs in the sense that those items, sub-BOMs, etc. have the material cost cost group assigned in the item master.

Can you double check that.

That is, what cost groups have the BOM items F-RM1, ... F-RM3 assigned?

Can you also test what happens if you add the 'manufacturing cost' cost group into the calculation for the overhead?

Would be a good test to see if the calculation works at all.

Best regards,

Ludwig

Reply
Karthik responded on 15 May 2019 2:35 AM

Hi Ludwig,

Thank you for the update.

Please find below comments.

1. Yes we have activated and saved the costing sheet.

2. Cost group is attached (Materials) for each raw material. i.e, F-RM1... F-RM3 Below is screenshot for reference.

3. If we attach manufacturing cost group in calculation tab in costing sheet, accordingly manufacturing overheads cost is updating twice. since already one component is created separately for manufacturing overheads.

Cost group:

Costing sheet:

Price calculation form:

Regards,

Karthik

Reply
Suggested Answer

Hi Karthik,

Thank you for testing this.

Can you revert your setup back to the material cost group as before?

In addition, can you check two things:

1. What parameters are selected in the calculation group STD?

2. Does your material related cost group have the type 'direct materials' selected.

I would expect that there is an issue with no. 1

Would be great if you could double check that.

Many thanks and best regards,

Ludwig

Reply
Karthik responded on 15 May 2019 4:30 AM

Hi Ludwig,

Thank you for the update.

Please find the below screenshot for calculation group "STD" and Cost group for direct materials.

Regards,

Karthik

Reply
Suggested Answer

Hello Karthik,

I think all your setup looks all good so far.

Can you check a last thing for me.

What do you see in the general tab of the costing sheet setup form for your material costs.

In one of your previous screenprints, I noticed the subtype 'level'.

Yet, if I saw the elements correctly then you use sub-Boms and do not have something on the same level.

Can you try using the subtype total and/or sublevel instead?

Best regards,

Ludwig

Reply
Suggested Answer

Hello Karthik,

How is the calculation of the overhead defined?

Can you check this in the setup of the costing sheet?

Is it possible that the % amount is set to 0?

Best regards,

Ludwig

Reply
Suggested Answer

Hello Karthik,

Do your sub-Boms (F-RM1, ... F-RM3) have cost prices setup in the costing version STD?

Are those sub-Boms assigned to the material and/or manufacturing cost groups?

Best regards,

Ludwig

Reply
Suggested Answer

Hello Karthik,

Can this be a date issue?

I noticed that your overhead is active from 10 May.

Has the production order been recorded and posted before the date the overhead % value was active or valid?

Best regards,

Ludwig

Reply
Suggested Answer

Forgot to mention:

Also try if you can enter a site specific overhead in the costing sheet to see if this makes a difference.

Best regards,

Ludwig

Reply
Suggested Answer

Hello Karthik,

Have you actually saved and activated the costing sheet through the buttons on top?

What I do not know is whether the production order that you processed has material costs included.

Material costs in the sense that those items, sub-BOMs, etc. have the material cost cost group assigned in the item master.

Can you double check that.

That is, what cost groups have the BOM items F-RM1, ... F-RM3 assigned?

Can you also test what happens if you add the 'manufacturing cost' cost group into the calculation for the overhead?

Would be a good test to see if the calculation works at all.

Best regards,

Ludwig

Reply
Suggested Answer

Hi Karthik,

Thank you for testing this.

Can you revert your setup back to the material cost group as before?

In addition, can you check two things:

1. What parameters are selected in the calculation group STD?

2. Does your material related cost group have the type 'direct materials' selected.

I would expect that there is an issue with no. 1

Would be great if you could double check that.

Many thanks and best regards,

Ludwig

Reply
Suggested Answer

Hello Karthik,

I think all your setup looks all good so far.

Can you check a last thing for me.

What do you see in the general tab of the costing sheet setup form for your material costs.

In one of your previous screenprints, I noticed the subtype 'level'.

Yet, if I saw the elements correctly then you use sub-Boms and do not have something on the same level.

Can you try using the subtype total and/or sublevel instead?

Best regards,

Ludwig

Reply
Suggested Answer

Hi Karthik, 

Can you restructure your costing sheet a bit and include subnotes, such as the ones that you find in the contoso usmf company?

If you setup the calculation in a similar manner, things should work out properly. 

Best regards, 

Ludwig

Reply
Suggested Answer

Hello Karthik, 

The only thing left is the type of the folder that was created

If you have this setup also in this way and things still do not work then contact a developer to debug. 

Best regards, 

Ludwig

Reply

SBX - Two Col Forum

SBX - Migrated JS