SBX - Search With Button

SBX - Forum Post Title

AR - Account number for transaction type Exchange rate gain does not exist - KB No longer available

Microsoft Dynamics AX Forum

bRradlyJames asked a question on 15 May 2019 10:57 AM
My Badges

Question Status

Suggested Answer

When running Accounts receivable -> Periodic -> Foreign currency revaluation -> Foreign currency revaluation:

I receive the following error:

I found the following thread along these same lines:

https://community.dynamics.com/ax/f/33/t/152061?pi61711

Using that thread, I have narrowed this down to the USD currency and I checked the following locations for Exchange Rate Gains/Loss accounts:

  1. [Entity] -> General ledger -> Setup -> Ledger
  2. [Entity] -> General ledger -> Setup -> Currency -> Currency revaluation accounts (Accounts for USD are specified)
  3. [Entity] -> General ledger -> Setup -> Posting -> Accounts for automatic transactions

I have also looked at the following KB:

https://fix.lcs.dynamics.com/Issue/Resolved?kb=2912586

However, when I go to 'Download' this KB it says the hotfix is no longer available.  

Am I missing anything in the setup?

Is there a way to still get this KB?

Reply
Suggested Answer

Hi,

Have you already tried setting up this posting type in the automatic posting account section in GL?

Best regards,

Ludwig

Reply
bRradlyJames responded on 15 May 2019 12:29 PM
My Badges

Ludwig,

Yes.  Same error persisted.

Interesting thing here is that we haven't received this before.  This error is new.

Reply

Hi bRadlyJames,

Have you implemented an upgrade or made some code changes?

Since when do you experience this issue and what is your exact system version? Is it R3?

Best regards,

Ludwig

Reply
bRradlyJames responded on 15 May 2019 2:43 PM
My Badges

Ludwig,

No upgrade has occured.  We deploy bug fixes / enhancements on a monthly basis, however, I'm not seeing any of our code changes from last month having an affect on this.

We experienced this for the first time this past Friday.  We are on R2 CU6.

The good news is that our AX Partner archived the KB that is supposed to fix this.  I'm preparing an environment to test it.

Reply
Suggested Answer

Good morning, 

I had a quick look at the hotfix and was able to download it. 

https://fix.lcs.dynamics.com/Issue/Details?kb=2912586&bugId=907481&dbType=0&qc=049fe9f2e5dacd01a38092504810450e997a21d20dbdfa9adb4bb54529b9cdb4

Next time probably try using a different browser?!

Anyway, hope that this fix resolves your issue. 

Please keep us updated in case any subsequent questions may arise. 

Many thanks and best regards, 

Ludwig

Reply
bRradlyJames responded on 16 May 2019 8:48 AM
My Badges

Ludwig,

Oh my goodness.  I can't believe I forgot to use IE... My fault.  KB is available for download.  Thank you!

Reply
bRradlyJames responded on 16 May 2019 9:38 AM
My Badges

Ludwig,

I was able to download the 'Package'.  It appears to have A LOT of KBs.  However, after looking in the Models folder, I couldn't find 2912586.  I would prefer to install this KB on it's own, rather than the hundreds of other KBs that I don't need.

Reply

Right. Carfully test this in a demo/test environment if you install the individual fix and let some users do some additional testing to make sure things work fine.

All the best,

Ludwig

Reply
bRradlyJames responded on 16 May 2019 12:36 PM
My Badges

Ludwig,

Thank you.  Will do.  I have my test environment all set up and ready to go.  Just need to get a stand alone KB.  Thanks!

Reply
bRradlyJames responded on 21 May 2019 8:52 AM
My Badges

Ludwig,

Sadly, it doesn't appear KB2912586 can be retrieved on it's own.  I attempted to install the entire Hotfix contained on LCS, however, I have encountered over 1400 compile errors.  This isn't going to work as this is almost like a small upgrade.  We would have to test our entire system to continue with this hotfix and we don't have time to do that.

I'm reaching out to our partner to see what else we can do.  Thanks!

Reply

Hi bRadlyJames,

Also try to reach out to the MS support. Maybe they are able to provide you with the single hotfix only.

Not sure if they can do that but it might be worth asking.

Best regards,

Ludwig

Reply
bRradlyJames responded on 22 May 2019 9:29 AM
My Badges

Ludwig,

Where can I go to reach out to MS support?  Our current partner appears unwilling to bring this up with Microsoft.  Can I approach MS Support myself?

Reply
Zoila Goñi Vera responded on 22 May 2019 5:46 PM

Hello, i have the same problem....   :-(   , you should have a  Partner who give you support (before Microsoft)

in my case the problem happens only with a customer.

regards

Reply
Suggested Answer

Hello bRadlyJames,

You should be able to open a support case directly with MS. If you provide your contact details, they should contact you directly.

Best regards,

Ludwig

Reply
bRradlyJames responded on 23 May 2019 9:12 AM
My Badges

Zoila,

My Revaluation error comes from the AR module as well.  I was able to get a hold of the single KB and I am testing a fix.  I will follow up here if it works.

Reply
Suggested Answer

Hi,

Have you already tried setting up this posting type in the automatic posting account section in GL?

Best regards,

Ludwig

Reply
Suggested Answer

Good morning, 

I had a quick look at the hotfix and was able to download it. 

https://fix.lcs.dynamics.com/Issue/Details?kb=2912586&bugId=907481&dbType=0&qc=049fe9f2e5dacd01a38092504810450e997a21d20dbdfa9adb4bb54529b9cdb4

Next time probably try using a different browser?!

Anyway, hope that this fix resolves your issue. 

Please keep us updated in case any subsequent questions may arise. 

Many thanks and best regards, 

Ludwig

Reply
Suggested Answer

Hello bRadlyJames,

You should be able to open a support case directly with MS. If you provide your contact details, they should contact you directly.

Best regards,

Ludwig

Reply

SBX - Two Col Forum

SBX - Migrated JS