CRM 2015 online Solution import failed

Question Status

Verified
Hari Bingi asked a question on 2 Nov 2015 8:28 AM

I am trying to import unmanaged solution in Test Environment(2015 online update) and the Import is failed due to Workflow(but it is a business rule)

Error is 0x80040217 processtrigger With Id = [GUID] Does Not Exist

I checked in DEV & TEST environment and both environments have this Business rules with same GUID and Same GUID for processtrigger.

Note : The same solution i tried to imported couple of weeks back from Dev to Test and it was successful. 

Import is being failed if solution contains entity(System or Custom) with Business Rules. Even solution import fails even if the solution is imported to same environment(DEV) from where it is exported. 

Import is being successful if solution contains entity(System or Custom) with no Business Rules.

Any help is appreciated.

Thanks In advance.

Hari.

Reply
James Rees responded on 30 Nov 2015 4:52 AM

Is the workaround something that can be posted here? 

Reply
Daniel Ovadia responded on 30 Nov 2015 5:29 AM

Hi Hari,

where do you have this Information that they have a fix for?

Microsoft told us the following:

Unfortunately there is no COD fix for this issue at the moment. However I could see that product team is working on it and has decided to release the fix as part of Update 0.3.

 

As of now the workaround I can propose is to remove the business rule from the solution which is causing the issue. I could also see the comment from product team as upgrading to CRM 2015 Update 1 as other solution, but I need double check on this before confirming this..

Hari please tell us the Case number so that we can get the fix also, thanks!

Reply
Hari Bingi responded on 30 Nov 2015 8:41 AM

Hi James,

For workaround you need to contact MS, this workaround need to be done along with support team.

MS said they run a script before import of solution, which will strip of the effecting business rules. Then we need to import the solution.

They said they have tried this option on their Test servers copying our CRM instances on them. And it was reported this workaround worked for them.

When asked for other option, MS says business rules error issue is fixed CRM v7.1.1 .

So, we are not interested in this workaround and abandoned this option and decided to import solution when we upgrade our existing CRM system to v7.1.1 . We are due for this upgrade third week of this month.

Thanks,

Hari Bingi

Reply
Hari Bingi responded on 30 Nov 2015 8:51 AM

Hi Daniel,

I did communicate with MS support when I faced this issue. They were ready to test along with me by 2nd week of this month.

Our business decided to import solution after our CRM instances updated by next month to v7.1.1 , and MS said verbally in meeting calls that this is not effecting v7.1.1 .

If the issue is caused by 1 or 2 business rules, it makes sense deleting those business rules. I had more than 50 business rules. Even I tried deleting 4 business rules and error is shown for other business riles :( .

Thanks,

Hari Bingi

Reply
Pradipto responded on 8 Dec 2015 8:04 AM

Is it possible to downgrade to Update 0.1 until this issue is fixed?

Reply
Suggested Answer
Anubhav Bajpai responded on 11 Jan 2016 4:22 PM

Hi Hari,

Could you verify for the scope of the Business Rules are set to All Forms instead of Information or specific form. I was able to import the solution after changing the scope to "All Forms".

You may try while any update from Microsoft comes through.

Do let me know if this works for you as well.

Thanks & Regards,

Anubhav

Reply
felipegs responded on 20 Apr 2016 10:42 PM

The problem is solved by deleting the target Business Rules, finally if you are importing a new versión of them, there would not be a problem to do this, so delete all business rules and import them again using your updated solution.

Hope this helps.

Reply
Hari Bingi responded on 21 Apr 2016 3:44 AM

This issue we faced when our CRMo was on CRM Online 2015. We have upgraded to CRM Online 2015 Update(7.1.1.4466) and we don't face any issues with Business Rules now while deployment.

Thanks,

Hari.

Reply
felipegs responded on 21 Apr 2016 10:46 AM

Yes, I considered necessary to answer because this issue has not been soved in CRM On-Premises 2015 0.2.

Reply
William Faulk responded on 28 Apr 2016 10:57 PM

I can confirm this as a continuing issue. They should have either withdrawn 0.2 or fixed it for on premise. It really causes issues with our deployments!

Reply
Vin.k.S responded on 4 May 2017 4:19 AM

It's is an known bug to Mircosoft and It was fixed with https://support.microsoft.com/en-us/help/3124850/service-update-1-for-microsoft-dynamics-crm-online-7.0.2 when they released it on 14 Jan 2016 but sadly it's only available for Online CRM.

Reply
ALTOSHAAM responded on 19 Jun 2017 12:16 PM

felipegs

The problem is solved by deleting the target Business Rules, finally if you are importing a new versión of them, there would not be a problem to do this, so delete all business rules and import them again using your updated solution.

Hope this helps.

This approach worked for me like a charm.

Thanks for simple solution!

Fortunately, I don't need to re-import Business Rules frequently.

Actually, I prefer not to use them at all.

They still have a lot of issues starting from their introduction in CRM 2013.

Reply
Verified Answer
Aiden Kaskela (MVP) responded on 2 Nov 2015 7:10 PM

Hi Hari,

I haven't seen this issue before but I've seen other people having this problem. If you haven't already, try the steps from this post (ronaldlemmen.blogspot.com/.../processtrigger-error-messages-and.html ). Like I said, I haven't had the issue personally so I can't attest to that solution, but it's worth a shot.

Hope this helps! I'd appreciate if you would mark this as a Verified answer.

Thanks,

 Aiden

Reply
Suggested Answer
Hari Bingi responded on 3 Nov 2015 3:22 AM

Hi Aiden,

Thanks for reply and link.

The error we facing is for all Business rule in all entities.

I tried deleting 2 workflows and it shows error for next available Business rule.

As we can not delete all Business rules in all entities, I am just waiting for Microsoft to respond on this as I raised a service ticket with Microsoft and currently they are working on this.

BR

Hari Bingi

Reply
Suggested Answer
Anubhav Bajpai responded on 11 Jan 2016 4:22 PM

Hi Hari,

Could you verify for the scope of the Business Rules are set to All Forms instead of Information or specific form. I was able to import the solution after changing the scope to "All Forms".

You may try while any update from Microsoft comes through.

Do let me know if this works for you as well.

Thanks & Regards,

Anubhav

Reply