SBX - Search With Button

SBX - Forum Post Title

[BUG?] [SDK] When a PublishAllXmlRequest is executed It's not possible to Import Solution using SDK

Microsoft Dynamics CRM Forum

  • Vitor Mendes posted on 22 Nov 2018 11:42 AM

    PublishAllXmlRequest publishRequest = new PublishAllXmlRequest();

    PublishAllXmlResponse publishResponse = (PublishAllXmlResponse)Service.IOrganizationService.Execute(publishRequest);

    When this Message is used to Publish all content, if I try import a solution using:

    ImportSolutionRequest ISR = new ImportSolutionRequest();
    ISR.CustomizationFile = File.ReadAllBytes(file);

    ImportSolutionResponse result = (ImportSolutionResponse)Service.IOrganizationService.Execute(ISR);

    This always return a System.ServiceModel.QuotaExceededException saying that "The size necessary to buffer the XML content exceeded the buffer quota."

    I tried to wait 5 - 10 - 20 min and resend the execute of this message, but always the same exception appear. And in dynamics CRM it's possible to import the solution normally.

    Reply
  • Radu Chiribelea responded on 23 Nov 2018 6:41 AM
    My Badges

    Hello,

    Maybe i did not understood your issue properly. Are you trying to import the solution after you get the PublishAllXmlResponse (after Publish All was finished) or before (while publishing all customizations)?

    Regards,

    Radu

    Reply
  • Vitor Mendes responded on 23 Nov 2018 12:29 PM

    I did a mistake, this QuotaExceededException is a problem on the missing dependencies, I don't know why this not show the System.ServiceModel.FaultException that show the missing dependencies. But the cause is not the publish.

    Reply
  • Rolando R responded on 24 May 2019 3:29 PM

    Hi Vitor,

    Can you elaborate on how you fixed this issue? Which assemblies were you missing?

    I am having same error but slightly different scenario.

    see my post, thanks.

    https://community.dynamics.com/crm/f/117/t/349327

    Reply

SBX - Two Col Forum

SBX - Migrated JS