SBX - Search With Button

SBX - Forum Post Title

CRM image freezes / rendering stops

Microsoft Dynamics CRM Forum

JakobQez asked a question on 16 May 2019 2:56 AM

Question Status

Suggested Answer

Hello,

We have a user in our organization that is sadly experiencing that her "CRM" suddenly freezes, and by that i mean:

When the user is editing information on a contact and then proceeds to click Save & Close the "image" then freezes and shows a blank white screen where the contact information used to be. The user is able to click on the home button (Microsoft Dynamics CRM) and the url and tab changes to the homepage. But the image is still stuck on this blank white contact screen. This problem usually happens after an hour so i suspect this might be some memory issue?

 

The user is working with Microsoft Dynamics CRM 2016 on-premise on a Citrix Virtual desktop server, and is using Internet Explorer.
I can provide video footage of when the error occurs, if needed.

I hope someone can help us! :-)

Kind Regards

Jakob

Reply
Pranav Shroti responded on 16 May 2019 6:58 AM
My Badges
Suggested Answer

I would imagine if its the save button then there is some login JS or Plugin (Sync) which is causing this operation to hand. This could happen for following reasons:

1. User is trying to access a particular record in background which he/she is not having access to or taking to long - Check this user's security role

2. JS/Plugin which is stuck in its operation and waiting for some dependency to respond back.

3. Check if normal "save button" on ribbon or save button at the bottom right corner is working for that user?

Hope this helps.

Reply
Suggested Answer

Hi

I would try the following

01. Let the user try the same out side of Citrix Environment if possible

02. Try on different browser like Chrome if possible and if its not allowed via group policy, you can try in IE Private mode

03. Make sure this user is on the same Citrix profile as the other users.

04. If possible try and login as different user on this user's machine and see if you still get the same error.

Reply
JakobQez responded on 16 May 2019 8:28 AM

Hi Pranav,

I'm somewhat certain that the problem doesn't lie in any of your stated reasons, cause the user has the necessary security roles to see what she needs to see.

The save button on the ribbon works, aswell as the save & close button, only until after an hour of work her CRM starts acting weird and then clicking the Save & Close button graphically freezes CRM.

I also forgot to mention that there are also other "graphical" errors that occur before the freezing happens.  I will post screenshots of these graphical errors.

Regards,

Jakob

Reply
JakobQez responded on 16 May 2019 8:34 AM

Hi Kokulan,

1. When the user works with CRM out of the Citrix environment it works flawlessly, though there is a catch - she works with CRM in Microsoft Edge.

2. She sadly can't work in Chrome, cause we have a permanent graphical issue, where the text is white in some our of custom fields. Which means that you're not able to see the text without selecting it.

3. She is on the same Citrix Profile as all of the other users which works with CRM.

4. CRM works fine with her own user when she is working with CRM out of the Citrix environment.

Reply
JakobQez responded on 16 May 2019 8:53 AM

Please see the following images, which shows graphical errors that occurs before CRM freezes:

Image below shows a section appearing twice:

i.imgur.com/vzj8MY5.png

Image below shows that the ribbon missing, where the Save & Close button should be.

i.imgur.com/OJVOkQp.png

Reply
Pranav Shroti responded on 16 May 2019 11:49 PM
My Badges
Suggested Answer

Hi Jakob - did you check the memory utilization of your client machine... I faced the similar issue with one of my customer... in my investigation, found out that there was a third party CTI provider which was causing the memory leak and hence browser memory consumption was flying off the roof.

I would suggest following:

1. Check with user his/her machine config like RAM and habits of using - are many application open at the same time etc.

2. Check if you have third party controls on your form.. or any JS which is loading something...

PS: I am not able to open your images.

Reply
JakobQez responded on 20 May 2019 2:31 AM

Hi again Pranav,

What do you exactly mean by "third party CTI provider"?

1. Check with user his/her machine config like RAM and habits of using - are many application open at the same time etc.

The user has the following applications open in Citrix:

  • 2 tabs of CRM running in Internet Explorer
  • 1 tab of Competella Agent Access running in Internet Explorer
  • Microsoft Outlook
  • Microsoft Word

2. Check if you have third party controls on your form.. or any JS which is loading something...
I will speak to our CRM developer regarding this. 



Here are the images:

Ribbon is missing, where the Save & Close button should be.

Duplicated custom field, which is also overlapping

Reply
Pranav Shroti responded on 16 May 2019 6:58 AM
My Badges
Suggested Answer

I would imagine if its the save button then there is some login JS or Plugin (Sync) which is causing this operation to hand. This could happen for following reasons:

1. User is trying to access a particular record in background which he/she is not having access to or taking to long - Check this user's security role

2. JS/Plugin which is stuck in its operation and waiting for some dependency to respond back.

3. Check if normal "save button" on ribbon or save button at the bottom right corner is working for that user?

Hope this helps.

Reply
Suggested Answer

Hi

I would try the following

01. Let the user try the same out side of Citrix Environment if possible

02. Try on different browser like Chrome if possible and if its not allowed via group policy, you can try in IE Private mode

03. Make sure this user is on the same Citrix profile as the other users.

04. If possible try and login as different user on this user's machine and see if you still get the same error.

Reply
Pranav Shroti responded on 16 May 2019 11:49 PM
My Badges
Suggested Answer

Hi Jakob - did you check the memory utilization of your client machine... I faced the similar issue with one of my customer... in my investigation, found out that there was a third party CTI provider which was causing the memory leak and hence browser memory consumption was flying off the roof.

I would suggest following:

1. Check with user his/her machine config like RAM and habits of using - are many application open at the same time etc.

2. Check if you have third party controls on your form.. or any JS which is loading something...

PS: I am not able to open your images.

Reply

SBX - Two Col Forum

SBX - Migrated JS