Hello everyone,

I'm running into a circular issue, it seems. I have a solution that uses a plugin. This plugin is registered by means of Xrm Toolbox with the Plugin Registration tool installed. In this case it is a webhook that gets triggered. This webhook works marvelous.

However, when I run the deployment pipeline in order to move the app from development to the UAT environment, it complains that "Some dependencies are missing", and it refers to the (what the development environment currently shows as) plugin. See the image below.



This "plug-in step" can't be exported, as far as I can see. 

So, I recreated this plug-in step in the UAT environment. By hand, completely identical. And also the Cloud Flow that gets triggered by this plugin. Because this needs a trigger (plug-in) on a specific URL, unique for that environment. Names, contents, actions, steps, everything unique. So, the missing dependencies now exist on the target environment as well.

The result is, that the pipeline still doesn't deploy the solution, with the same error, pointing in the general direction of the plug-in.

I can think of one reason that this happens; both plugin-ins have a unique ID themselves, whereas when the plug-in were to be deployed by the pipeline, it would have the identical ID of the plug-in at the development environment. That is merely an assumption though. Is this assumption correct?

My main question is; how do I get the pipeline running again? Does anyone have an idea of where to look next?

Many thanks in advance,
- Alex.